Jump to:

10931 Posts in 2614 Topics by 1810 members

All other Modules

SilverStripe Forums » All other Modules » 2 modules I made

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 6265 Views
  • lanks
    Avatar
    Community Member
    61 Posts

    Re: 2 modules I made Link to this post

    Hi roterl

    I really like the widgets manager. I am having some trouble using it however. Where I create a new 'Managed Widgets Area Holder', add my widgets and then save it the widgets are re-ordered in some random order. If I then go back, reorder them and save again it just saves them back to the original order.
    If you can give me any ideas as to why this is happening or a fix that would be great.

    Thanks
    Liam

  • Bauer-CTU
    Avatar
    Community Member
    10 Posts

    Re: 2 modules I made Link to this post

    Hi,
    Upon saving the WidgetsManager is re-ordering my widgets as well, just like the previous poster is experiencing.
    For me it seems to work fine with 4 widgets but when I add a 5th widget it re-orders them.

    Does anyone know how to solve this?

    Many thanks in advance.

  • Aljoscha
    Avatar
    Community Member
    2 Posts

    Re: 2 modules I made Link to this post

    Hi there!

    I need help with the WidgetManager:

    I'm new to SilverStripe. I installed the calendar module and the calendar widget, created a new calendar and some events.
    Now I want to show the calendar widget at the frontpage - I use BrightSide1 as template.
    So I installed - seems to be the easiest way - the WidgetManager and created a WidgetHolder, have named it and chosen the calendar widget and the calendar.
    In the page.ss of BrightSide1 I added $SidebarWidgets after the SideNav-tag.
    I flushed the site but nothing appears.

    Where is my mistake?

    Thanks a lot for your help.
    Aljoscha

  • GrizzlyGroundswell
    Avatar
    Community Member
    10 Posts

    Re: 2 modules I made Link to this post

    Thank you for this widgetmanager! It makes it so much easier for this newbie! However, can you let me know where exactly I place the $widgetmanager ? I know it is a newbie question, but I am still learning SilverStripe! My theme is "fancypants" and my site is www.theodoremedia.com Thank you in advance!

    Update: It took me a while, but after putting $SidebarWidgets in mytheme/template/layout/page.ss and _page.ss It worked like a bloody Rippa! Thanks so much for all your hard work! Still learning here!

  • GrizzlyGroundswell
    Avatar
    Community Member
    10 Posts

    Re: 2 modules I made Link to this post

    so far so good in 2.4.4!

  • Anirath
    Avatar
    Community Member
    7 Posts

    Re: 2 modules I made Link to this post

    I seem to be having an issue with the latest Widget Manager. I used the "Widgets Manager" tab and created a new Widget Area and added the LoginWidget I wanted to use. Then I went to the page and used the "content/managed widgets" and selected Managed then selected my widget area and saved. However, it doesn't show on the page when I flush the cache. Any help?

  • Anonymous user
    Avatar
    Community Member
    8 Posts

    Re: 2 modules I made Link to this post

    Hi Roterl

    I'm having trouble getting the Widget Manager to work properly in SS 2.4.4.

    I have it installed and the $SidebarWigets in the navigation.ss page

    The Managed widgets tab shows up in the CMS OK but the only way I can get any widgets to display is to make select "Self" managed. IF I select any other option they don't show up at all. I also wanted to have a widget on every page - say quicklinks but I can't make that work either. Any ideas?

    Cheers
    Pete

    6265 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.