Jump to:

10994 Posts in 2728 Topics by 1819 members

All other Modules

SilverStripe Forums » All other Modules » [SOLVED] User forms 0.2 + Mollom 0.2 + SS 2.4 = Fatal Error ?

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 886 Views
  • heady
    Avatar
    Community Member
    2 Posts

    [SOLVED] User forms 0.2 + Mollom 0.2 + SS 2.4 = Fatal Error ? Link to this post

    Hi,

    i have begun to build my site in local without configure the mollom public an private keys. All worked fine.

    Since i have uploaded it online and configure the mollom keys i get this error:

    Fatal error: Class MollomSpamProtector contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (SpamProtector::getFormField) in /homez.344/iameddy/www/mollom/code/MollomSpamProtector.php on line 68

    _config.php is well with:

    Mollom::setPublicKey("XXXXXXXXXXXXXX");
    Mollom::setPrivateKey("XXXXXXXXXXXXXX");
    SpamProtectorManager::set_spam_protector('MollomSpamProtector');

    And spam protection 0.3 is installed too.

    So have i forgotten something or is it a compatibility problem with SS 2.4 or else?

    Thank you for your feedback.

  • heady
    Avatar
    Community Member
    2 Posts

    Re: [SOLVED] User forms 0.2 + Mollom 0.2 + SS 2.4 = Fatal Error ? Link to this post

    I have solved the mistake with the last trunk of mollom.

    886 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.