Jump to:

10994 Posts in 2728 Topics by 1819 members

All other Modules

SilverStripe Forums » All other Modules » CMSWorkflow Module wont install

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2587 Views
  • patjnr
    Avatar
    Community Member
    101 Posts

    Re: CMSWorkflow Module wont install Link to this post

    Thanks WIll

    it worked.

    ta

    PAt

  • Tama
    Avatar
    Community Member
    130 Posts

    Re: CMSWorkflow Module wont install Link to this post

    I'm getting the following error on installing Workflow:

    Fatal error: Class 'PopupDateTimeField' not found in /var/www/dev01/workflow/code/batchactions/BatchSetEmbargo.php on line 19

    This is directly installed from the following SVN: http://svn.silverstripe.com/open/modules/cmsworkflow/tags/rc/1.0-rc3/

    We're running 2.4, do we need to install legacydatefields as suggested by Willr for this to work?

  • Tama
    Avatar
    Community Member
    130 Posts

    Re: CMSWorkflow Module wont install Link to this post

    I installed legacydatefields from: http://svn.silverstripe.com/open/modules/legacydatetimefields/trunk/ - and everything is now working fine.

  • mark_s
    Avatar
    Community Member
    78 Posts

    Re: CMSWorkflow Module wont install Link to this post

    Hi.

    FYI, legacydatatimefields was introduced for modules that have not been migrated to the new date field classes introduced with 2.4. The short-medium term plan with cmsworkflow is to wean it off legacydatetimefields.

    Mark

  • SilverDan
    Avatar
    Community Member
    5 Posts

    Re: CMSWorkflow Module wont install Link to this post

    Just thought I'd post in this thread, as I had a couple of minor issues with CMSWorkflow:

    I have a clean install of SS 2.4.2 and installed CMSWorkflow Module rc4. The Embargo and Expiry date and time functions (and popup datepicker timepicker) weren't working at all. I then installed the legacydatetimefields module which had no effect on the Embargo and Expiry functionality or date/time pickers either.

    I just downloaded and installed the older rc3 version of CMSWorkflow and this is now working as expected with all functionality including the old date/time pickers.

    So there could be some issue with the CMSWorkflow rc4 version with SS 2.4.2 and the following modules: dataobject_manager, image_gallery, uploadify - thought it might be worth a mention for anyone else struggling to get it working.

    UPDATE: 16/12/2010

    I just realised that some of the functionality with CMSWorkflow had dropped off when I reverted to rc3! Although the Date and Time fields/functionality began working correctly with rc3, the ability for publishers to actually publish or unpublish pages was lost! Obviously, this won't do, so I'm going back to rc4 and will have to do without functioning embargo/expiry! Anyone else having the same issue?

    2587 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.