Jump to:

10850 Posts in 2517 Topics by 1793 members

All other Modules

SilverStripe Forums » All other Modules » Subsites, root folder for file chooser?

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1146 Views
  • Wilson
    Avatar
    Community Member
    63 Posts

    Subsites, root folder for file chooser? Link to this post

    Hi everyone,

    In the CMS, has anyone been able to hide asset folders not owned by the selected Subsite for the user when using File Chooser, for example in the link tool? I thought it was working like this at one point, but now I see all of the directories for every subsite.

    I'm on 2.4 beta1.

    Thanks for any advice! And also, please let me know if it is actually supposed to be working like this and I've either messed it up or have incompatible version of subsites module.

    Thanks!
    Wilson

  • kindlemanwill
    Avatar
    Community Member
    63 Posts

    Re: Subsites, root folder for file chooser? Link to this post

    Bump.

    This seems to be broken. I'm getting the same results as Wilson - all the files and folders are shown when attaching an image but if you select one that is owned by a different subsite, it doesn't attach. No error message.

    Will

  • kindlemanwill
    Avatar
    Community Member
    63 Posts

    Re: Subsites, root folder for file chooser? Link to this post

    As far as i can see, this just hasn't been implemented. There isn't anything thats trying to make the fields work with subsites.

    I've tried to have a look at how to extend ImageField or probably FileIFrameField but not got very far. any pointers on how to proceed would be awesome.

    W

    1146 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.