Jump to:

10993 Posts in 2727 Topics by 1818 members

All other Modules

SilverStripe Forums » All other Modules » userforms installation location

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 775 Views
  • kevyn
    Avatar
    Community Member
    6 Posts

    userforms installation location Link to this post

    Please can someone tell me the exact location that the latest userform add on should be installed onto SS 2.4 ?

    ie. which of these is it? (or is it something else?)

    www.mydomain.com/userforms/trunk/files
    www.mydomain.com/userforms/modules/trunk/files
    www.mydomain.com/sapphire/userforms/trunk/files

    this is assuming that my root is where my sapphire, cms, mysite, and themes folders are.

    I'm new to SS and this is just throwing me totally - is there not just a folder called addons that all the addons should just be installed to?

    ps. I've tried the dev/flush - and it has built my database tables once - do I need to delete the tables before installing the add on again?

    thank you very much

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: userforms installation location Link to this post

    Its the same as every other module - the root of your silverstripe installation. Eg the folder which already has sapphire, cms etc.

    So your structure should be the following. Note if you download using the automatic download generator (or trac) it throws some version numbers in the filename or adds another needed level which needs to be removed

    assets
    cms
    --/ code
    --/ templates
    --/ etc...
    sapphire
    --/ api
    --/ core
    --/ etc..
    mysite
    --/ code
    --/ etc..
    userforms
    --/ code
    --/ templates
    --/ etc ..

    I'm new to SS and this is just throwing me totally - is there not just a folder called addons that all the addons should just be installed to?

    I am personally for a dedicated 'modules' folder so its easy - copy to modules/ and done. But some reasons why people don't want a simple solution like that. You can find discussions on the forum about this structure debate and on the dev mailing list.

  • kevyn
    Avatar
    Community Member
    6 Posts

    Re: userforms installation location Link to this post

    Thank very much Willr - I actually had it in the correct place at one point, it's just that when I tried to change an existing page to a user form, it said 'this will change once saved' but then it always reverted back, which made me think I had something wrong!

    I did have a weird problem, when I pressed 'add' button I just got a blank page (http://domain.com/index.php/admin/EditForm) - but pressing back let me use the form ok.

    Now when I save and publish the form, it just appears on my page like this:

    Contact

    $UserDefinedForm

    Generated with the default ContentController.ss template

    Is there something else I need to do to get it to display and use my template? Do I need to create a new page template or something? Sorry to be a pain, but the documentation seems to suggest it should just work

  • dacar
    Avatar
    Community Member
    168 Posts

    Re: userforms installation location Link to this post

    hi kevin,

    i hav got exactely the same problem: blank page and http://localhost/xyz/admin/EditForm
    I have made a new installation on wampp. SS Version 2.4.1.

    Can anybody help?

    hmmmm, just found this one: http://www.silverstripe.org/general-questions/show/289597#post289597

    775 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.