Jump to:

10846 Posts in 2516 Topics by 1792 members

All other Modules

SilverStripe Forums » All other Modules » Blog couldn't be shown in a subsite as a subsite virtual page

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 596 Views
  • musike
    Avatar
    Community Member
    3 Posts

    Blog couldn't be shown in a subsite as a subsite virtual page Link to this post

    Hello dear silverstripe developpers and users !

    I've installed the last Subsite module and the Blog module on a 2.4 silverstripe version.

    --> I've a Blog Holder in the Main site and I am trying to create a "Subsite virtual page" from the subsite which point to the blog holder in my Main site.

    If I go to published site to the subsite.mysite.org/blog page, I get an error : Fatal error: Call to a member function latestParam() on a non-object in /homepages/xx/xxxxxxx/htdocs/blog/code/BlogTree.php on line 300

    --> However, I can create a "Subsite virtual page" from the subsite which point to each BLOG ENTRIES . In this case, I can access to the entries of the main site, i.e. mysite.org/blogentry1 from subsite.mysite.org/blogentry1

    Do you know if it is possible to acces to the blog holder from a subsite and not only to entries ?
    Thank you !
    musike

    596 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.