Jump to:

10986 Posts in 2724 Topics by 1817 members

All other Modules

SilverStripe Forums » All other Modules » CMSworkflow Embargo/Expiry errors

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1075 Views
  • Hibari
    Avatar
    Community Member
    9 Posts

    CMSworkflow Embargo/Expiry errors Link to this post

    I recently put the cmsworkflow module into my site and whenever I try and set the embargo date and/or embargo date for the changes that I want on my page, the form layout doesn't fit that which matches the pdf. Also, I don't get the popup options of the calendar, and clicking the "Set embargo date" submit button doesn't actually set the embargo date or even load any code.

    I'm still pretty new to silverstripe and I guess this must be pretty lame, but could anybody help?

  • Hibari
    Avatar
    Community Member
    9 Posts

    Re: CMSworkflow Embargo/Expiry errors Link to this post

    I guess to be a bit more specific--

    When saving the page content to the way that I wish to have it change to upon a later date, I get the option down on the bottom right to "Request Publication" And when I do that, it's happy and fine and gives me the workflow page so that I can set the embargo date and expiry and review and approve if I feel the need to.

    When I get to the embargo/expiry section, there are no buttons to open up the calendar and pick the date or time. Neither Embargo or Expiry has the option to do so, and when clicking, "Set embargo date" The site does not load at all or run any information. So, pretty much, they're just useless and not helpful at all. The site definitely needs this ability for updating content that needs to go up and come down on certain months and days. If anybody has had the same issue, or knows how to fix it, I'd really appreciate any help that I can get.

    (Note:)
    The batch functions don't have the pop-ups either, and when clicking to make something batch a embargo/expiry date, it said 0 success 1 failure and does not set the date for the embargo or expiry. That whole function is just not working.

  • DsX
    Avatar
    Community Member
    178 Posts

    Re: CMSworkflow Embargo/Expiry errors Link to this post

    I am having the same problems exactly.

    Also I have a page on my site that gives an error that is related to cmsworkflow. It is a news page where I have articles (as pages not dataobjects) and they are listed. The page is fine until I try to publish a new article using the request publish process. In the CMS it appears as if I get the article published but the frontend holderpage errors out.

    Besides the above error, my CMSworkFlow problems are exactly the same as yours, so I suspect that it either doens't like the version of 2.4x we are using or there are additional config settings to add.
    I have not added any of the WorkflowRequest:: settings (I don't think they are manditory) nor have I added any cron script yet (but that shouldn't effect this) I have tried with and with out LeftAndMainCMSWorkflow::set_prompt_admin_for_comments(false); just to see what the difference is (doesn't effect the core problems)

    have you had any further luck?

    1075 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.