Jump to:

10851 Posts in 2517 Topics by 1793 members

All other Modules

SilverStripe Forums » All other Modules » Mobile module & SS 2.4.3

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1492 Views
  • bones
    Avatar
    Community Member
    103 Posts

    Mobile module & SS 2.4.3 Link to this post

    I was just about to start writing a theme for iPhone when I noticed the Mobile module. Fab. Except that I can't get it to work.

    The CMS side of it seems fine, I've selected "mobile users see mobile theme, but no redirection occurs", and the "blackcandymobile" theme, but viewing on my iPhone (iPhone 4, iOS 4.2) just shows the non-mobile theme.

    Does the module work with SS 2.4.3, or is there any additional configuration that I might have missed?

    Also, if I select "Mobile users are redirected to a mobile domain", my iPhone returns a "Server cannot be found" error. Any idea what might be the cause of that?

    Many thanks.

  • LinseyM
    Avatar
    Community Member
    99 Posts

    Re: Mobile module & SS 2.4.3 Link to this post

    EDIT: solved this, see: http://silverstripe.org/all-other-modules/show/15564

    Hi there,

    Did you have any luck getting the mobile CSS to display without redirecting to a mobile site?

    I am having same problem - site does not show mobile stylesheets.

    CHeers, Linsey

  • bones
    Avatar
    Community Member
    103 Posts

    Re: Mobile module & SS 2.4.3 Link to this post

    Thanks, Linsey, I followed your other post and that aspect of it now works fine

    I've not had any luck with the redirection (but I've not really done anything to try and fix it yet- I'm just concentrating on writing my theme).

  • LinseyM
    Avatar
    Community Member
    99 Posts

    Re: Mobile module & SS 2.4.3 Link to this post

    hi there - no probs.

    the redirection probably won't work unless you set up the sudomain on your server.

    e.g. you currently have a site set up as www.domainname.com

    but you'd need to go into your hosting contorl panel and set up your subdomain, eg mobile.domainname.com

    Usually this is all done in / around the control panel bit with the DNS etc. If in any doubt then ask the techie support before you change anything.

    I reckon that will fix it. (Way to test - change the redirect domain to anything else, like http://www.google.co.uk and it will probably work...)

    Lx

  • bones
    Avatar
    Community Member
    103 Posts

    Re: Mobile module & SS 2.4.3 Link to this post

    I've set up a subdomain (m.mysite.com) in cPanel, and enabled "Mobile users are redirected to mobile domain", but all I get is a 404 error. Sorry, I don't know much about subdomains and DNS :/

    1492 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.