Jump to:

10930 Posts in 2613 Topics by 1810 members

All other Modules

SilverStripe Forums » All other Modules » Help Help Help embargo-expiry-module error

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 477 Views
  • Funfair77
    Avatar
    Community Member
    49 Posts

    Help Help Help embargo-expiry-module error Link to this post

    Hello I have SS 2.4,

    There is a problem with the embargo-expiry-module http://www.silverstripe.org/embargo-expiry-module/ .
    I put the folder on my server, run dev/build and flush. Tables where created.

    I checked the admin, and there was an internal server error 500 ...getitem?ID=1&ajax=1
    Page in the tree can't be loaded. popup massage with no info appears. Error loading.

    I deleted the folder, run dev/build page in the BE tree can be loaded again. :o)

    Ok, I installed an other module with the same functanality, CMS Workflow. This module also doesn't work.

    I deleted the folder, run dev/build page and try again embargo-expiry-module, upload folder etc.

    Nothing happens, server error 500 and blank screen :o(

    Ok, what's the trick :o)

    I hope someone can give me the solution to give an expire date with an page.

    Marnix

  • swaiba
    Avatar
    Forum Moderator
    1784 Posts

    Re: Help Help Help embargo-expiry-module error Link to this post

    Hi,

    Did you see this?

    "Note: The workflow module supercedes this module."

    I think that will help instead of this... if you hang out on IRC you'd probably find simon_w and ask him, but I'd guess he would say use the newer module.

  • Funfair77
    Avatar
    Community Member
    49 Posts

    Re: Help Help Help embargo-expiry-module error Link to this post

    Hello Swaiba,

    Thank you for your fast reply!

    Yes, I saw that 'supercedes' note.

    I installed the latest release: embargoexpiry-v0.2.2.tar.gz (Compatible with: SilverStripe 2.3, 2.4)
    When this module gives an error, I deceided to install the 'CMS Workflow' module. Also error, see my first post.

    Marnix

  • swaiba
    Avatar
    Forum Moderator
    1784 Posts

    Re: Help Help Help embargo-expiry-module error Link to this post

    Ha! my bad... in that case I'd stick to...

    if you hang out on IRC you'd probably find simon_w and ask him

    he knows quite a bit about silverstripe ;-)

  • Funfair77
    Avatar
    Community Member
    49 Posts

    Re: Help Help Help embargo-expiry-module error Link to this post

    Problem solved! Thanks for the IRC tip Swaiba.

    You just need the legacy date time fields
    So, first install http://www.silverstripe.org/legacydatetimefields-module/ and then http://www.silverstripe.org/embargo-expiry-module/ . Done!

    Marnix

    477 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.