Jump to:

10845 Posts in 2513 Topics by 1792 members

All other Modules

SilverStripe Forums » All other Modules » Working Gallery Plugin for SS 3

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9 10 11
Go to End
Author Topic: 8906 Views
  • SnowBoarder82
    Avatar
    Community Member
    52 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    Great thanks for the update thi3r!!

    Just to clarify for anyone else coming up with the same issue - the latest branch of GridFieldBulkEditing tools has had the file GridFieldBulkEditingTools.php removed and therefore the class GridFieldBulkEditingTools (which is referenced in the Gallery module in GalleryPage.php) no longer exists. Simply uncommenting the line in GalleryPage.php seems to have fixed the issue.

  • arthurdent
    Avatar
    Community Member
    132 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    Hi OpticBlaze -- great to finally find a gallery module that's compatible with SS 3.0!!

    After numerous 'fatal error' 'white screens of death' I was able to install ss3Gallery without breaking anything in my SS3 local environment. The page type appears in the dropdown list and all looks good. It's just that when I go to save the page I get an 'Internal Server Error'.

    Any idea what might be going on?

  • arthurdent
    Avatar
    Community Member
    132 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    WTF is going on? Everytime I install ss3Gallery it makes SS3 crap out. Back to 'white screen of death' territory. Not just on the site I've developing but on a clean install, clean DB, standard 'Simple' theme... are there any image gallery extensions that work with SS3 at all? Or do I have to fall back to an version of SS2 that has compatible modules?

    It's really amazing that after almost a year this hasn't been sorted!!

  • arthurdent
    Avatar
    Community Member
    132 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    OK, still running GridFieldBulkEditingTools and SortableGridField no probs. Things turn to crap as soon as I add ss3Gallery - apologies for my rant a moment ago but I'm getting kind of desperate - this is taking much too long and I'm going around and around in circles. Can somebody - ANYBODY - shed a bit of light here before I revert to SS2.X... PLEASE!

  • Optic Blaze
    Avatar
    Community Member
    150 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    Hi arthurdent,

    I have packaged the version of Gridfieldbulkediting tools, SortableGridlfield as well as the latest version of SS3 Gallery that i have been using. There has been a couple of updates on the Gridfieldbulkeditingtools and SortableGridfield that i suspect is playing havoc with SS3 gallery. So have a look and see if this works.

    To see what the errors are (when you get the white screen of death) have you tried the following:

    # show php errors in htaccess
    php_flag display_startup_errors on
    php_flag display_errors on
    php_flag html_errors on

    Attached Files
  • arthurdent
    Avatar
    Community Member
    132 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    That's sweet OpticBlaze!! No errors, we're all good to go with your updated code. Thanks for supplying - I owe you one!!

  • arthurdent
    Avatar
    Community Member
    132 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    Seems I was a bit premature... ss3Gallery is loaded and can be seen in CMS - I can upload images fine, however all I'm getting on my page is an empty bulleted list - no link to image thumbnails. Did I miss something?

  • Optic Blaze
    Avatar
    Community Member
    150 Posts

    Re: Working Gallery Plugin for SS 3 Link to this post

    Hi there, this sounds like a template issue:

    - Check if you did a dev build
    - Make sure you dont have any other GalleryPage.ss files in your template>layout folder. Your previous installation could be interfering
    - Also check that you copy the prettyPhotoCustom.css file to you template>css directory so that you can write your own custom css. You should not seeing bullets
    - Dont forget to inlcude the prettyPhotoCustom.css file into your Page.ss file like so <% require themedCSS(prettyPhotoCustom) %> else it also wont work
    - I have included my prettyPhotoCustom.css file...check if it helps

    Attached Files
    8906 Views
Page: 1 2 3 4 5 6 7 8 9 10 11
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.