Jump to:

10928 Posts in 2612 Topics by 1809 members

All other Modules

SilverStripe Forums » All other Modules » Subsites Module on SS 3

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 567 Views
  • gaethofs
    Avatar
    Community Member
    9 Posts

    Subsites Module on SS 3 Link to this post

    Hi!
    I just started working with SS 3 and I'm trying to get all my modules working.
    Subsites isn't working right now.
    It's SS 3.01 freshly installed on a clean server,
    and the latest build from subsites (from github).

    I encountered a few problems when I was installing SS3.
    The first problem I had was with a fatal error on mcrypt_create_iv(64,1),
    I removed the function and used the older ones to fall back.

    After reinstalling, it worked and I could perform all the possible actions.
    The subsites module installed without a problem,
    and after adding new subsites and adding their domains,
    I bumped against another problem.

    The subsites were visible in the admin panel but when I was no longer able to add a new page
    in any of the sites, not even in the main site I had before installing the module.

    I increased all possible memory limits, but still, no change.

    Anyone encountered the same problem and got it working?

  • webdiv
    Avatar
    Community Member
    1 Post

    Re: Subsites Module on SS 3 Link to this post

    Same thing for me. I've been desperately waiting for subsites for 3.x to be released for months now. It was down in the roadmap as being something that would be released with 3.0 but was not. Now you can search and download the extension for 3.x but it is not functional. The best that can be said for it is that adding this extension will not crash your install like some of the other 3.x modules.

    I have two different projects now that were needing subsites that are in a holding pattern. It's a little frustrating for it to be offered as a download in its current form- it does not work.

    Yes I know I should be fixing the problem instead of whining. I've put my rep on the line getting people on board to use SilverStripe, but 3.x modules still have so many issues that I feel like we should have gone 2.x instead.

    567 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.