Jump to:

10931 Posts in 2614 Topics by 1810 members

All other Modules

SilverStripe Forums » All other Modules » DMS not working

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 641 Views
  • Dazman1
    Avatar
    Community Member
    30 Posts

    DMS not working Link to this post

    Hi All

    ive tried installing the new DMS Mod, but get a 500 internal server error when i try to load a page in the cms area.

    i drop the folder in root.
    dev/build (t builds databases)
    site loads fine
    put the site in dev mode no errors

    still no joy

    Any ideas
    thanks

    Darren

  • Dazman1
    Avatar
    Community Member
    30 Posts

    Re: DMS not working Link to this post

    I love silverstripe and have for the past 3-4 years, but the one thing that lets it down is the lack of community help.

    some times members can wait over 3 months for a response from any one.
    moan over.

    bet its 2-3 days before someone comments

  • the-tech-guy
    Avatar
    Community Member
    13 Posts

    Re: DMS not working Link to this post

    Bump!

    Anyone have an update on this?

    I have also tried to install the DMS module into my companies website for some basic document management and I have the same problem,

    I have copied the folder into the home directory, renamed it to "dms", emptied the cache and rebuilt the database but I can't access the backed, I too get the same problem "internal server error", is there something that I am missing?

  • Willr
    Avatar
    Forum Moderator
    5490 Posts

    Re: DMS not working Link to this post

    Please read the FAQ before posting. A 500 internal server error is a generic error, check your error logs for the actual error message or turn on dev mode. One thing I would check from experience is make sure the dms-assets folder (where DMS assets are stored) is writable by the web server.

  • the-tech-guy
    Avatar
    Community Member
    13 Posts

    Re: DMS not working Link to this post

    Hey Willr,

    I actually didn't know that the DMS had a FAQ or I would have read it first, my apologies.

    No when you say check that the folder is writeable, you are talking about setting permissions of the folder eg "7-5-5"

    Thanks for the idea's I will try turning on dev mode.

  • Willr
    Avatar
    Forum Moderator
    5490 Posts

    Re: DMS not working Link to this post

    Sorry, I was referring to the forum FAQ which covers the (not helpful) internal server error http://www.silverstripe.org/general-questions/show/16055.

  • BigMoose
    Avatar
    Community Member
    19 Posts

    Re: DMS not working Link to this post

    Hi, I was having the exact same headache for the better part of a week, but solved it for myself. One of the requirements for the DMS module to work is to also install the 'Grid Field Extensions' module:
    http://addons.silverstripe.org/add-ons/ajshort/silverstripe-gridfieldextensions

    This news is unfortunately very difficult to find as it makes no mention of this in the readme file, or anywhere on Github from what I can see. It only mentions: "PHP 5.3 with the "fileinfo" module (or alternatively the "whereis" and "file" Unix commands)"

    I just happened to come across the other requirement at the very bottom of:
    http://addons.silverstripe.org/add-ons/silverstripe/dms

    Under 'Versions'.

    I hope this works for you. Poor documentation and unhelpful responses make learning SilverStripe needlessly difficult.

    641 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.