Jump to:

10930 Posts in 2613 Topics by 1810 members

All other Modules

SilverStripe Forums » All other Modules » Comments module: PHP fatal error after install

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 884 Views
  • MarkusM
    Avatar
    Community Member
    11 Posts

    Comments module: PHP fatal error after install Link to this post

    Dear all,

    I installed the comments module from http://www.silverstripe.org/comments-module/ (v 1.0.0.) using SS 3.0.5. on Ubuntu. I copied the extracted folder to the root folder of my SS instance and did a rebuild without getting any error messages. Afterwards I got a "Server error
    Sorry, there was a problem handling your request." and the error message displayed at the bottom of this post in my error.log.

    Any help would be appreciated.

    Markus

    [Mon Apr 08 08:26:45 2013] [error] [client 127.0.0.1] PHP Fatal error: Couldn't
    run query: SELECT DISTINCT "SiteTree_Live"."ClassName", "SiteTree_Live"."Create
    d", "SiteTree_Live"."LastEdited", "SiteTree_Live"."URLSegment", "SiteTree_Live".
    "Title", "SiteTree_Live"."MenuTitle", "SiteTree_Live"."Content", "SiteTree_Live"
    ."MetaTitle", "SiteTree_Live"."MetaDescription", "SiteTree_Live"."MetaKeywords",
    "SiteTree_Live"."ExtraMeta", "SiteTree_Live"."ShowInMenus", "SiteTree_Live"."Sh
    owInSearch", "SiteTree_Live"."Sort", "SiteTree_Live"."HasBrokenFile", "SiteTree_
    Live"."HasBrokenLink", "SiteTree_Live"."ReportClass", "SiteTree_Live"."CanViewTy
    pe", "SiteTree_Live"."CanEditType", "SiteTree_Live"."ProvideComments", "SiteTree
    _Live"."Version", "SiteTree_Live"."ParentID", "SiteTree_Live"."ID", CASE WHEN "S
    iteTree_Live"."ClassName" IS NOT NULL THEN "SiteTree_Live"."ClassName" ELSE 'Sit
    eTree' END AS "RecordClassName" FROM "SiteTree_Live" WHERE ("URLSegment" = 'them
    es' AND "ParentID" = 0) ORDER BY "SiteTree_Live"."Sort" ASC LIMIT 1 | ERROR: co
    lumn SiteTree_Live.ProvideComments does not exist\nLINE 1 in /var/www/aep-ss/fra
    mework/model/Database.php on line 693

  • Willr
    Avatar
    Forum Moderator
    5489 Posts

    Re: Comments module: PHP fatal error after install Link to this post

    Are you sure your dev/build worked correctly? Comments master also requires 3.1 (see the 1.0 download for 3.0)

  • MarkusM
    Avatar
    Community Member
    11 Posts

    Re: Comments module: PHP fatal error after install Link to this post

    Pretty much yes. I fixed the problem by though by installing the comments module using composer as described here: An installation https://github.com/silverstripe/silverstripe-comments/blob/master/docs/en/Installing.md.

    884 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.