Jump to:

10993 Posts in 2727 Topics by 1818 members

All other Modules

SilverStripe Forums » All other Modules » Newsmodule 1.0 for SS3.0.x and higher.

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3
Go to End
Author Topic: 1043 Views
  • Brasil
    Avatar
    Community Member
    12 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    Thanks! I will do a fresh install this afternoon and let you know the result.

  • Sphere
    Avatar
    Community Member
    44 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    If possible, could you open an issue on github, with as much details as what steps you took to reproduce the error?
    (Installation-method, installed modules, etc.)

  • Brasil
    Avatar
    Community Member
    12 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    Hi Sphere,

    After reading this thread: https://github.com/colymba/GridFieldBulkEditingTools/issues/33 I comment out the same section as jenniferaslan did (in \code\objects\News.php from line 348 till 363) and now adding and edit messages seems to be works fine. But I didn't test everything yet. Maybe there is another issue now because I comment out this. I will test more tomorrow.

  • Sphere
    Avatar
    Community Member
    44 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    You're using the master_3.0, not the master for SS3.1?
    I would advise to switch to the 3.1 Silverstripe and GridFieldBulkEditingTools, it's way faster.

    But I assumed you were on master (which did have a bug by the way).

    I'll be checking and bugfixing the master_3.0 version asap, but it's only bugfixing, no new features like the master-branch.

  • Brasil
    Avatar
    Community Member
    12 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    Sphere,

    No I'm not using master_3.0, I'm using the master for ss3.1 on Silverstripe 3.1. I checked that many times and for sure I downloaded again this afternoon from Github.
    Also the GridFieldBulkEditingTools and SortableGridField are the latest versions.

  • Sphere
    Avatar
    Community Member
    44 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    Very strange you encountered this. I'm developing this module while being on the latest master or 3.1 versions all the time to make sure no bugs appear. The demo-website as described in the readme is also on the latest release (sometimes a few days behind) and doesn't show the behaviour you're describing.

    Nor is my local master or development branch, even when resetting a few commits back.

    I have no explanation, but if you can, could you install Firebug (if you haven't already) and set your environment to dev (in _config.php of mysite, set Director::set_environment('dev'); )
    Then, check the "Net" tab of Firebug, when submitting a new item (with the commented part uncommented again)?
    It should give you a more detailed error, because I'm completely unable to reproduce your error, even on a clean installation.

  • Brasil
    Avatar
    Community Member
    12 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    Sphere,

    I will do later this evening. I see we are from the same country

  • Sphere
    Avatar
    Community Member
    44 Posts

    Re: Newsmodule 1.0 for SS3.0.x and higher. Link to this post

    Really? I thought you were Brazilian!

    You got my e-mail for issues considering any work I ever done that's publicly on github ;) Contact me there, maybe a Skype-talk and/or any other method might be useful.

    1043 Views
Page: 1 2 3
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.