Jump to:

10994 Posts in 2728 Topics by 1819 members

All other Modules

SilverStripe Forums » All other Modules » DisplayAnything turns my site to crap!

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 219 Views
  • arthurdent
    Avatar
    Community Member
    163 Posts

    DisplayAnything turns my site to crap! Link to this post

    Liked the sound of DisplayAnything, sounded nice and easy to install, no accessory modules -- but it made my site die -- all I get is a white page. Just tried it with a fresh install of SS and the same thing happened. Is it a version thing (I'm using SS 3.0.5)? Anybody have any issues with this module?

  • arthurdent
    Avatar
    Community Member
    163 Posts

    Re: DisplayAnything turns my site to crap! Link to this post

    Right. I pulled the display_anything folder from my rood directory, rebooted the whole machine (not a matter of simply restarting MAMP), dropped display_anything folder in again, did a dev/build/ and presto:

    Creating database tables
    Email_BounceRecord
    File
    Field File.ClassName: changed to enum('File','Folder','Image','Image_Cached','WatermarkedImage','UploadAnythingFile','DisplayAnythingFile','DisplayAnythingYouTubeVideoFile') character set utf8 collate utf8_general_ci default 'File' (from enum('File','Folder','Image','Image_Cached') character set utf8 collate utf8_general_ci default 'File')
    Folder
    Image
    Image_Cached

    That was it. White screen territory. So I grabbed the message and went to post to this forum. White screen again! And this time on an external server! Whatever is happening with this module is breaking things at a very fundamental level!!

    Reboot machine and we're back in business. Going back to ImageGallery...

    219 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.