Jump to:

10977 Posts in 2720 Topics by 1815 members

All other Modules

SilverStripe Forums » All other Modules » Userforms module blank form tab

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 376 Views
  • neilberry
    Avatar
    Community Member
    6 Posts

    Userforms module blank form tab Link to this post

    Hi,

    I'm using SilverStripe 3.1. Trying to get the UserForms module to work (I grabbed the master file from GitHub) but I get a blank form tab with no ability to create a new form. I've done a dev build and flushed the cache etc but no change. Any ideas?

    Thanks
    Neil

  • haantje72
    Avatar
    Community Member
    69 Posts

    Re: Userforms module blank form tab Link to this post

    i have the same problem here.

    SS 3.1.2 NEW fresh install
    maxskitter is the only extra module installed

    Tried userforms master and 1.0... both the same problem

    Userforms installs well
    In dev mode finally got some errors:
    ViewableData->renderWith(SSViewer)
    LeftAndMain.php:588
    {closure}()
    call_user_func(Closure)
    PjaxResponseNegotiator.php:82
    PjaxResponseNegotiator->respond(SS_HTTPRequest)
    LeftAndMain.php:565
    LeftAndMain->show(SS_HTTPRequest)
    RequestHandler.php:288
    RequestHandler->handleAction(SS_HTTPRequest,show)
    Controller.php:194
    Controller->handleAction(SS_HTTPRequest,show)
    RequestHandler.php:200
    RequestHandler->handleRequest(SS_HTTPRequest,DataModel)
    Controller.php:153
    Controller->handleRequest(SS_HTTPRequest,DataModel)
    LeftAndMain.php:441
    LeftAndMain->handleRequest(SS_HTTPRequest,DataModel)
    AdminRootController.php:93
    AdminRootController->handleRequest(SS_HTTPRequest,DataModel)
    Director.php:360
    Director::handleRequest(SS_HTTPRequest,Session,DataModel)
    Director.php:152
    Director::direct(/admin/pages/edit/show/13,DataModel)
    main.php:189

    i can create the page... tricky view (it doesnt open but when pressing reload it shows with errors above) it but cannot create the form itself... its a blank page. All other tabs seems to work!

    further it breaks tinyMCE colorpopup. It opens now like a totally new page by selecting the color and when selected it goes back to the normal state.

  • haantje72
    Avatar
    Community Member
    69 Posts

    Re: Userforms module blank form tab Link to this post

    Ive found an update that works...

    I did a flush on the actual page in the CMS and it returned. eg. yoursite... /admin/pages/edit/show/3?flush=1

    So load the page... if it does not reload the page after clicked on the formpage
    then when showed the id get an flush=1 after it...

    for me the form shows now and tiny mce works fine!!!

  • neilberry
    Avatar
    Community Member
    6 Posts

    Re: Userforms module blank form tab Link to this post

    Thanks, got it working in the end using the master file... https://github.com/silverstripe/silverstripe-userforms/tree/master

    Seems strange you have to flush the cache on the admin as well (although didn't work on branch 1.0) - sometime Silverstripe is confusing ;)

    376 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.