Jump to:

10931 Posts in 2614 Topics by 1810 members

All other Modules

SilverStripe Forums » All other Modules » Image Gallery Extension: Testers Needed

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Go to End
Author Topic: 76348 Views
  • Blairos
    Avatar
    Community Member
    7 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    Oops - just read the page for dataobject_manager - shows the SVN link there... <blush> - trying this out now

  • Blairos
    Avatar
    Community Member
    7 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    Update: All is sorted now - I ended up trashing everything and reinstalling SS from scratch

    Have set up SVN for the Image gallery and associated components - everything now works perfectly

    Thanks for your assistance with this UncleCheese!

  • Stephan
    Avatar
    Community Member
    55 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    Hello Uncle Cheese,
    thanks very much for your great work.
    Is there any possibility to change the interface language ?
    As far as I see there is no possibility to use a lang file.
    It would be a great possbility if we can make translations to your module.

    CU Stephan

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    Yup. It's been on my list for a while. Just need to get to it. I'll make a post here when the translation tags are in.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    Translation tags are in.

  • micahsheets
    Avatar
    Community Member
    164 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    I had the image gallery working really well until today when I updated to the latest versions of image_gallery, dataobject_manager, and swfupload. Now when I try to upload an image or images I get two popups. One says "An error occurred in the upload. Try again later." and then when I click ok on that one another pops up that says "There was a problem with the upload.
    The server did not accept it.". When I look at the folder that the file uploaded to I see that the file is there but the table in the database does not list it as an ImageGalleryItem. I have checked permissions on the files and folders and they are correct.

    So as a troubleshooting step I took an older site that I had on the same server using a slightly older version of swfupload and image_gallery and tested that I could still upload to that one and it works perfect. I then put the new versions of those two modules up and I now get the same behavior on the old site with the popup errors. I tried to put the older versions back but still get the error. This is very puzzling. Im not sure where to go from here but I was supposed to have this new site up on the live server for my client tomorrow.

    So it seems that upgrading to the new versions of swfupload and image_gallery does not work and even makes it so you cannot go back. I have not tried making a brand new install of SS 2.3.1 and installing the image_gallery and see what happens. I may try that tomorrow.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    I have been able to replicate the problem. Working on it now.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension: Testers Needed Link to this post

    This bug should be fixed. I had forgotten to deploy the parentIDName change from FileDataObjectManager to the ImageGalleryManager, as well.

    76348 Views
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.