Jump to:

10992 Posts in 2727 Topics by 1818 members

All other Modules

SilverStripe Forums » All other Modules » Image Gallery Extension Troubles

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5
Go to End
Author Topic: 8532 Views
  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Image Gallery Extension Troubles Link to this post

    I'm trying to install the image gallery extension (which looks awesome btw) but I'm having all kinds of trouble getting it to work. I can't find any documentation on how to get started. Where do I put the files? Within the root folder or the gallery module. After I flush the db do I make a ss template file called ImageGalleryPage.ss? If so what do I call from there? It looks like there may have been more stuff written on this before the forum redesigns. Hopefully someone can lend a hand. Thanks in advance!

  • themagician
    Avatar
    Community Member
    5 Posts

    Re: Image Gallery Extension Troubles Link to this post

    The lightbox 2.0 pop up effect doesn't work for me on the demo at http://demo.silverstripe.com/gallery/ it just goes to another page containing the image. Does anyone one else have this problem?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Hi, there,

    I'm the developer of the Image Gallery extension. Hopefully I can help you out.

    @the magician

    The demo site is running the original version of the gallery, using Lightwindow 2.0, which does not work in Safari. It's also on SS 2.2.1, so I wouldn't be too worried about things not working there.

    @Andrew

    I've been meaning to write up some docs. I should have some soon. Here's the basic idea. The Image Gallery extension runs on top of the Gallery extension, so you need to download that first. I know they've taken it down. I'm going to start bundling it with the module or just make it independent all together, since with every version they become more and more distinct from each other.

    Drop the folder in your root silverstripe folder, and do a build. You should now be able to create an Image Gallery page in the CMS. If you have a Gallery page already, make sure you change its behavior to ImageGallery Page.

    You must have an album in which to put your photos. By default, you get "Default Album." You can rename this as you like, but if you try to delete it, it will come back because it is not possible to have zero albums. In the popup window for the album, you can create a new folder to store your photos, or, if you already have a bunch uploaded somewhere else, you can point it to one of those folders with the "use existing folder" option. Save the album, and add any others you want.

    Now, on the front end, the image_gallery folder should give you the necessary templates to get you started. Go to the page and you should get a list of the albums. If you only have one album, it will skip that step and jump right to it. If you're logged in, you'll get some admin controls, including Upload photos, move photos, etc. Click upload, and you'll start an upload queue for that album. Select as many photos as you want and click Save. At the next step you'll be able to add captions. Save, and you'll return to the gallery view. If you don't see your new photos, do a hard refresh. Sometimes the old page caches.

    To test out your gallery, click "hide admin controls" and you'll get the experience of a regular user.

    That should be good for now. Let me know how you do and I'll get started on docs.

  • pi
    Avatar
    Community Member
    1 Post

    Re: Image Gallery Extension Troubles Link to this post

    The Lightwindow doesn't seem to work on my install. In Opera, firefox and IE7.
    I am using sliverstripe 2.2.3

    All it seems to do is open a page with the image.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Hmm... Lightwindow isn't included with the Image Gallery extension. Are you sure that's what you're using? Try selecting a different one in the Popup tab.

  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Thanks for all the hard work and help w/ this extension! I'm still finding some things confusing, but I'm starting to get the hang of things. My admin controls allow for edits and drag and drop features. However, I still can't upload to the gallery from that part of the interface, I get a save button, but I have no browse type button, am I missing something. Thanks again for your help!

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Chances are your Flash player needs to be updated. Please confirm that you can use this demo:

    http://demo.swfupload.org/v220beta4/applicationdemo/index.php

    If you can't use that demo, your Flash Player is definitely out of date. If you can, let me know what version you're running. I'd be really interested to know what's causing this.

  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Thanks for the quick reply, I've got no problems using that demo you sent.

    8532 Views
Page: 1 2 3 4 5
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.