Jump to:

10989 Posts in 2726 Topics by 1817 members

All other Modules

SilverStripe Forums » All other Modules » Image Gallery Extension Troubles

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5
Go to End
Author Topic: 8522 Views
  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    I think I know the problem. This sounds really dumb, but can you check your DOCTYPE? For some reason, the uploader doesn't work with an XML doctype, and the SS themes use that by default.

    If you don't know what I'm talking about, just paste the top 10 lines or so of your HTML source code on the upload page.

  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Thanks for your help...

    This is the doctype

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

    Should I change that?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    That's really weird. Try it on my website here:
    http://sandbox.carlinowebdesign.com/gallery/album/people/upload

    u; admin
    p: password

    Hopefully we can figure out if it's client side or server side.

  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Re: Image Gallery Extension Troubles Link to this post

    I'm attaching a screenshot of my test site, and how it looked on the demo you sent me to. Maybe something is screwy in my theme, or where I placed the files.

    For now I'm gonna try to put the extension on a local copy of silverstripe w/ the black candy theme to see if that works. I'll get back to you on that. Thanks again for all your help.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Looks like it's working on my install and not on yours. On that site I'm running 2.3. You might want to try upgrading.

    Otherwise, I'd start by just checking if you can get it to work on the default black candy theme and then go from there. Thanks for all your testing. If you can flush out a bug, I'd love to know about it. Keep me posted.

  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Re: Image Gallery Extension Troubles Link to this post

    I'm trying to install a test blackcandy theme on my MAMP setup. I have everything up and running, but when I try to run a db build with the extension folders (image_gallery and swfupload) it fails to run. If I don't add the swfupload file, it will run and I can make an ImageGallery page type, however all the upload stuff of course doesn't work. Is there a something I should look for in my local server to get things to working w/ the swf upload stuff.

    Otherwise I'll attempt to get things running on a remote server w/ ss2.3rc2.

  • Andrew Houle
    Avatar
    Community Member
    132 Posts

    Re: Image Gallery Extension Troubles Link to this post

    I switched my layout to the blackcandy theme and the upload works fine. I'm not sure why my customized theme doesn't allow things to work. I'll keep digging around. Any ideas on why that would be?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Image Gallery Extension Troubles Link to this post

    Ah-ha! Okay, send me the full template(s) for your custom theme. I'll play with it and see if we can figure out where it was going wrong. Thanks for your help. I really want to squash all these bugs. Appreciate you flushing it out.

    8522 Views
Page: 1 2 3 4 5
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.