Jump to:

10848 Posts in 2516 Topics by 1792 members

All other Modules

SilverStripe Forums » All other Modules » Fatal Error!!!!

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1757 Views
  • Fading
    Avatar
    Community Member
    15 Posts

    Fatal Error!!!! Link to this post

    My browser came up with this Fatal Error:

    Warning: require_once(C:/wamp/www//swfupload/code/SWFUploadFileIFrameField_Uploader.php) [function.require-once]: failed to open stream: No such file or directory in C:\wamp\www\silverstripe-v2.2.3\swfupload\_config.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required 'C:/wamp/www//swfupload/code/SWFUploadFileIFrameField_Uploader.php' (include_path='.;C:\php5\pear;C:\wamp\www\silverstripe-v2.2.3\auth_openid\code;C:/wamp/www/silverstripe-v2.2.3/sapphire/parsers/') in C:\wamp\www\silverstripe-v2.2.3\swfupload\_config.php on line 3

    Everything is where it is supposed to be. Can anyone assist me in resolving this.

    Thank you

  • Hamish
    Avatar
    Community Member
    712 Posts

    Re: Fatal Error!!!! Link to this post

    Have you tried to add a 'swfupload' module?

    Not familiar with it, but the issue is with that directory. If you don't need it (or know what it is), remove the folder or rename _config.php to _config.php.old.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Fatal Error!!!! Link to this post

    Hi, Fading,

    I developed the SWFUpload module, and that is a bug that has been resolved in a newer version. As a quick fix, please update your swfupload/_config.php to read:

    require_once(Director::baseFolder() . "/swfupload/code/SWFUpload_Uploader.php");
    require_once(Director::baseFolder() . "/swfupload/code/SWFUploadFileIFrameField.php");

    Stay tuned for a new version. I'm adding some new stuff as we speak.

  • Fading
    Avatar
    Community Member
    15 Posts

    Re: Fatal Error!!!! Link to this post

    Thank you very much for your response guys.

    Where do I make those changes at?

    Thx

  • UncleCheese
    Avatar
    4085 Posts

    Re: Fatal Error!!!! Link to this post

    /swfupload/_config.php

  • Fading
    Avatar
    Community Member
    15 Posts

    Re: Fatal Error!!!! Link to this post

    Nothing changed, still the same fatal error.

  • Near
    Avatar
    Community Member
    1 Post

    Re: Fatal Error!!!! Link to this post

    Try this...

    require_once(Director::baseFolder() . "/swfupload/code/SWFUploadFileIFrameField_Uploader.php");
    require_once(Director::baseFolder() . "/swfupload/code/SWFUploadFileIFrameField.php");

  • soft-systems
    Avatar
    Community Member
    11 Posts

    Re: Fatal Error!!!! Link to this post

    That last one worked for me - Thanks

    1757 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.