Jump to:

10993 Posts in 2727 Topics by 1818 members

All other Modules

SilverStripe Forums » All other Modules » Mollom Install - Tab showing in admin

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 278 Views
  • merrick_sd
    Avatar
    Community Member
    95 Posts

    Mollom Install - Tab showing in admin Link to this post

    Mollom does not seem to be installing ..well nothing showing in the admin area.

    when i do dev/build i cannot see any tables relating to mollom are created.

    I have used composer to download spamprotection and mollom.
    I have created a yml file in eg: mysite -> _config ->spamprotection.yml

    ---
    name: spamprotection
    ---
    FormSpamProtection:
    default_spam_protector: MollomSpamProtector
    Mollom:
    public_key: <a2the-rest-of- my-key-ends-here>
    private_key: <43the-rest-of- my-key-ends-here>

    i do dev/build?flush=1 but the results don't show anything relating to Mollom

    ..there used to be a tab in the admin, so you knew it was installed

    I always managed to get it installed before.

    this is my first attempt since we can't use the _config.php any more
    //SpamProtectorManager::set_spam_protector('MollomSpamProtector');

    // Configure Mollom API keys
    //these are for *.myserverdomain and nothing else
    //please signup for you free one at http://mollom.com eg add site mydomain.co.uk if you wish to use mollom
    //for http://ccsw.co.uk
    //MollomServer::setPublicKey('a2fffffffff');
    //MollomServer::setPrivateKey('43fffffff');

    Am i doing something wrong regards to the yml file maybe ...i don't have any errors.

    I have looked at tickets on github

    it should be FormSpamProtectionExtension: not FormSpamProtection

    not that iit has made any difference.

  • rosie
    Avatar
    Community Member
    2 Posts

    Re: Mollom Install - Tab showing in admin Link to this post

    Hi,

    I have just been trying to install mollom and finding it quite confusing.
    I put the same details in the spamprotection.yml

    After a lot of errors the main problem seemed to be that there was no mollom.class.inc file in folder vendor/mollom/client.
    I downloaded the module https://github.com/mollom/MollomPHP and put it in this folder and this has made the errors go away.
    Not sure if that was a problem for you also?

    I also don't get a menu item in admin either.

    I haven't being able to work out where I put the instruction below from the SpamProtection module from https://github.com/silverstripe/silverstripe-spamprotection (I am rather new to silverstripe, probably obvious to others), can someone tell me?

    To add spam protection to your form instance call enableSpamProtection.

    // your existing form code
    $form = new Form( .. );
    $form->enableSpamProtection();

    Cheers
    Rosie

    278 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.