Jump to:

10986 Posts in 2724 Topics by 1817 members

All other Modules

SilverStripe Forums » All other Modules » Cannot Add Fields to User Defined Form

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2
Go to End
Author Topic: 2403 Views
  • Insight
    Avatar
    Community Member
    4 Posts

    Cannot Add Fields to User Defined Form Link to this post

    Hi all, I've got this problem where I cannot add a field to the user defined form. If I click on a field, such as a text box, nothing happens. The page remains the same and no field is added to the form. We have used previous versions of SilverStripe and this never happened.

    Can anyone help?

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    If you are using 2.3 , make sure you use the latest version of userforms.

  • Insight
    Avatar
    Community Member
    4 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    I'm using version 0.1.0.

    Is that the latest?

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    Yeah, that is the latest.

    Works for me , using 2.3.0 ....

  • Insight
    Avatar
    Community Member
    4 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    How can I work out why it's not working?

  • Novabomb
    Avatar
    Community Member
    2 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    In order for the userforms addon to work properly you must change one of two things.

    • Rename the folder to userforms from userforms-v0.1.0
    • OR
    • Edit the _config.php file in the userforms-v0.1.0 folder to point the javascript and css files to the userforms-v0.1.0 directory.

    Enjoy!

  • Insight
    Avatar
    Community Member
    4 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    Thanks.

    The module now allows me to add fields.

    However, the new problem that arises is that the form that arrives via email has no contents.

    There is a subject, but nothing in the email.

    Also the submissions page is empty.

    Any suggestions how to fix this?

  • boogieg
    Avatar
    Community Member
    23 Posts

    Re: Cannot Add Fields to User Defined Form Link to this post

    I'm having the same issue with being unable to add fields. My folder is named userforms and everything appears to be in order as far as I can tell from what Novabomb said. I click the fields to add them, but nothing happens. I've attached a screenshot. Any help is greatly appreciated.

    Attached Files
    2403 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.