Jump to:

10993 Posts in 2727 Topics by 1818 members

All other Modules

SilverStripe Forums » All other Modules » Preview: SlideshowPro Module

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9
Go to End
Author Topic: 13403 Views
  • UncleCheese
    Avatar
    4085 Posts

    Re: Preview: SlideshowPro Module Link to this post

    Transparent should be a checkbox, you're right. What is the value of WMode if it is not transparent?

  • bod
    Avatar
    Community Member
    72 Posts

    Re: Preview: SlideshowPro Module Link to this post

    Normally if you are not using transparent then the Wmode param is not included in the html export from Flash however if it makes it hard to switch between including it all or not then you could use the value opaque which is the (undeclared usually) default.

    the three values for swfs are

    window
    opaque
    transparent

  • bod
    Avatar
    Community Member
    72 Posts

    Re: Preview: SlideshowPro Module Link to this post

    thinking about it, maybe a drop down with opaque as default, what do you think?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Preview: SlideshowPro Module Link to this post

    Perfect. Thanks.

  • UncleCheese
    Avatar
    4085 Posts

    Re: Preview: SlideshowPro Module Link to this post

    Run an update and try it out. I don't have an environment to test it right now, so I'm crossing my fingers for no syntax errors.

  • bod
    Avatar
    Community Member
    72 Posts

    Re: Preview: SlideshowPro Module Link to this post

    Will do! Nice one!

  • bod
    Avatar
    Community Member
    72 Posts

    Re: Preview: SlideshowPro Module Link to this post

    Hi Uncle Cheese, Well so far so good re that update apart from one thing which I don't think is a direct result of that particuliar update but perhaps a general bug?

    If your SlideshowPro page contains the $SearchForm tag the search gets broken and returns the following error message

    Website Error
    Forbidden

    The website server has not been able to respond to your request.

    Contact an administrator: administrator [at] yoursite [dot]com

    apending ?isDev=1 to the url gives,

    Action 'SearchForm' isn't allowed on class SlideshowProPage_Controller

  • bod
    Avatar
    Community Member
    72 Posts

    Re: Preview: SlideshowPro Module Link to this post

    So, re my post above - any ideas why the Site search is breaking in the SlideshowPro page Uncle Cheese? Can't fathom it myself - SlideshowPro extends ImageGallery which in turn extends Page so the class inheritance would appear to be breaking for that specific function somehow :o/

    13403 Views
Page: 1 2 3 4 5 6 7 8 9
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.