Jump to:

10989 Posts in 2726 Topics by 1817 members

All other Modules

SilverStripe Forums » All other Modules » Save and Publish as a 'Publisher' doesn't work in Workflow module

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 990 Views
  • klikhier
    Avatar
    Community Member
    150 Posts

    Save and Publish as a 'Publisher' doesn't work in Workflow module Link to this post

    Have launched another SS site today

    Have changed set_environment_type to 'live' only to find out that I could no longer use the 'Save and Publish' button to save and publish changes. When I do, I have to comment on the change (normal part of cmsworkflowmodule) and next, SS tells me changes have been saved and published, but SS is not telling me the truth here: nothing has changed.

    I am using the cmsworkflow module and am logged in as a Publisher (so WITH save-and-publish-permissions). After some testing I found that, as a Publisher, I can only change, save and publish stuff by clicking 'Save' first followed by clicking 'Save and Publish'. This is an extra step and hard to explain to my client (I hate writing manuals

    Anyone else having the same issue/solution?

    Happy to hear, many thanks in advance.

    PS. SilverStripe 2.3.1

  • klikhier
    Avatar
    Community Member
    150 Posts
    990 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.