Jump to:

10979 Posts in 2722 Topics by 1815 members

All other Modules

SilverStripe Forums » All other Modules » Help with SWFUpload Field

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1611 Views
  • dannny
    Avatar
    Community Member
    5 Posts

    Help with SWFUpload Field Link to this post

    I tried to install Image gallery module and it depends on SWFUpload field, so i installed it. I looked back at the normal file upload section and it was no longer usable. I looked around for a different way to upload files, and i found nothing. Not only that, but i found nothing related to SWFUpload. I dunno, maybe im not looking in the right place, or maybe my module install is wrong. Where would i find what was included with the SWFUpload module, and how can i upload files now?

  • UncleCheese
    Avatar
    4085 Posts

    Re: Help with SWFUpload Field Link to this post

    What do you mean "no longer usable?"

  • dannny
    Avatar
    Community Member
    5 Posts

    Re: Help with SWFUpload Field Link to this post

    i guess it doesnt load the css, and there is no upload field, the files are no longer links... There is no upload field. The regular files/images section no longer works. Where can i use swfupload to upload and use files on my site? Ive attached an image of the files/images section.

    Attached Files
  • UncleCheese
    Avatar
    4085 Posts

    Re: Help with SWFUpload Field Link to this post

    Make sure the folders of the three modules are:

    "swfupload"
    "dataobject_manager"
    "image_gallery"

    For some reason, Silverstripe appends the -rXXX revision to the folder name and then the dependencies don't get pulled in.

  • dannny
    Avatar
    Community Member
    5 Posts

    Re: Help with SWFUpload Field Link to this post

    They werent appended, but my names for dataobject manager and imagegallery were missing the underscores. After adding them in, it worked perfectly. Thanks a lot.

  • Jnauta
    Avatar
    Community Member
    8 Posts

    Re: Help with SWFUpload Field Link to this post

    I have the SWFUpload working, however i am having trouble being able to access file in the folders. I must upload a new image each time i want to use it with the ImageDataObjectManager. Any thoughts?

    1611 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.