Jump to:

10979 Posts in 2722 Topics by 1815 members

All other Modules

SilverStripe Forums » All other Modules » Is GoogleSitemap Module Working?

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1599 Views
  • Viv
    Avatar
    Community Member
    30 Posts

    Is GoogleSitemap Module Working? Link to this post

    My understanding after reading the documentation page ( Google Site Maps ) was that the Google sitemap is automatically generated as a sitemap.xml file. Also, when changes are made, SS informs Google of the changes.

    I am using SS 2.3.3 stable with the GoogleSiteMaps module built-in. The sitemap.xml file appears to be generated fine when going to: www.mysite.co.nz/sitemap.xml. However, in my Webmaster tools account, for the site it states that there are 'no sitemaps submitted'. I thought it might be a time thing for Google to come back and index the site - I figured Google would search for and find a sitemap.xml file (eventually).

    Do I need to submit an initial sitemap url to Google (ie. the www.mysite.co.nz/sitemap.xml) to kick things off? Will SS then inform Google of the changes automatically as above? How can I check this?

  • Willr
    Avatar
    Forum Moderator
    5497 Posts

    Re: Is GoogleSitemap Module Working? Link to this post

    I believe you should submit it to the google directory initially, to enable Google notifications (this is turned off by default) you need to set GoogleSitemap::enable_google_notification(true); in your mysite/_config file.

  • Viv
    Avatar
    Community Member
    30 Posts

    Re: Is GoogleSitemap Module Working? Link to this post

    Wow, very impressive response time to my query - thanks. That sounds just what I need to know.

    1599 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.