Jump to:

10993 Posts in 2727 Topics by 1818 members

All other Modules

SilverStripe Forums » All other Modules » User Defined Forms Error!

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1584 Views
  • AndrewMK
    Avatar
    Community Member
    23 Posts

    User Defined Forms Error! Link to this post

    Hi I have just upgraded to Silverstripe 2.3.3 and userdefinedforms 0.2 and now i am getting this error and i cannot work out why?

    Error: DataObjects have been requested before the manifest is loaded. Please ensure you are not querying the database in _config.php.
    At line 2257 in C:\wamp\www\sdc_internet\sapphire\core\model\DataObject.php

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: User Defined Forms Error! Link to this post

    Can you post the whole back log of the error - UserForms should not be requiring anything before the manifest is built.. Try running yoursite.com/dev/build/?flush=1

  • AndrewMK
    Avatar
    Community Member
    23 Posts

    Re: User Defined Forms Error! Link to this post

    tried a dev/build and this didnt resolve anything. Here is the entire error.

    Error: DataObjects have been requested before the manifest is loaded. Please ensure you are not querying the database in _config.php.
    At line 2257 in C:\wamp\www\sdc_internet\sapphire\core\model\DataObject.php
    user_error(DataObjects have been requested before the manifest is loaded. Please ensure you are not querying the database in _config.php.,256) line 2257 of DataObject.php DataObject->buildSQL((FormID = '500') AND (`FormID` = '500'),,,,1,) line 2346 of DataObject.php DataObject->extendedSQL((FormID = '500') AND (`FormID` = '500'),,,) line 454 of TableListField.php TableListField->getQuery() line 410 of TableListField.php TableListField->sourceItems() line 265 of ComplexTableField.php ComplexTableField->FieldHolder() call_user_func_array(Array,Array) line 408 of ViewableData.php ViewableData->XML_val(FieldHolder,,1) line 73 of .cacheC..wamp.www.sdc_internet.sapphire.templates.TabSetFieldHolder.ss include(C:\WINDOWS\Temp\silverstripe-cacheC--wamp-www-sdc_internet\.cacheC..wamp.www.sdc_internet.sapphire.templates.TabSetFieldHolder.ss) line 354 of SSViewer.php SSViewer->process(TabSet) line 773 of ViewableData.php ViewableData->renderWith(TabSetFieldHolder) line 62 of TabSet.php TabSet->FieldHolder() call_user_func_array(Array,Array) line 408 of ViewableData.php ViewableData->XML_val(FieldHolder,,1) line 58 of .cacheC..wamp.www.sdc_internet.sapphire.templates.TabSetFieldHolder.ss include(C:\WINDOWS\Temp\silverstripe-cacheC--wamp-www-sdc_internet\.cacheC..wamp.www.sdc_internet.sapphire.templates.TabSetFieldHolder.ss) line 354 of SSViewer.php SSViewer->process(TabSet) line 773 of ViewableData.php ViewableData->renderWith(TabSetFieldHolder) line 62 of TabSet.php TabSet->FieldHolder() call_user_func_array(Array,Array) line 408 of ViewableData.php ViewableData->XML_val(FieldHolder,,1) line 69 of .cacheC..wamp.www.sdc_internet.sapphire.templates.Includes.Form.ss include(C:\WINDOWS\Temp\silverstripe-cacheC--wamp-www-sdc_internet\.cacheC..wamp.www.sdc_internet.sapphire.templates.Includes.Form.ss) line 354 of SSViewer.php SSViewer->process(Form) line 773 of ViewableData.php ViewableData->renderWith(Array) line 982 of Form.php Form->forTemplate() line 1005 of Form.php Form->formHtmlContent() line 381 of LeftAndMain.php LeftAndMain->getitem(HTTPRequest) line 162 of Controller.php Controller->handleAction(HTTPRequest) line 129 of RequestHandler.php RequestHandler->handleRequest(HTTPRequest) line 122 of Controller.php Controller->handleRequest(HTTPRequest) line 277 of Director.php Director::handleRequest(HTTPRequest,Session) line 121 of Director.php Director::direct(/admin/getitem) line 118 of main.php

  • AndrewMK
    Avatar
    Community Member
    23 Posts

    Re: User Defined Forms Error! Link to this post

    Im still getting the above error and am at quite a loss as to how to resolve. Does anyone have any ideas?

  • Willr
    Avatar
    Forum Moderator
    5508 Posts

    Re: User Defined Forms Error! Link to this post

    And if you remove the userforms module the site works fine?

  • AndrewMK
    Avatar
    Community Member
    23 Posts

    Re: User Defined Forms Error! Link to this post

    The site works fine even with the userforms module installed. It is only when i create or navigate to a user defined form pagetype that the error occurs.
    To clarify if i browse to the page the forms appear. if i browse to the admin page in the CMS i get the error

  • AndrewMK
    Avatar
    Community Member
    23 Posts

    Re: User Defined Forms Error! Link to this post

    So i performed a bit more testing and i created a brand new site (2.3.3) and installed the exact same modules and theme from my current site and the Userforms works perfectly????

    im very much at a loss as to what could be causing this error!

    1584 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.