Jump to:

11004 Posts in 2735 Topics by 1824 members

All other Modules

SilverStripe Forums » All other Modules » Dashboard Module

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1 2 3 4 5 6 7 8 9 10 11
Go to End
Author Topic: 15658 Views
  • UncleCheese
    Avatar
    4085 Posts

    Re: Dashboard Module Link to this post

    I've never understood this error. It doesn't come from DOM. It comes from way upstream. RequestHandler.php, I believe is the class that throws the error. I wish I knew more about what causes it. My guess is that changing the url from /admin/EditForm/ID/etc/etc to /admin/content/EditForm/ID/etc/etc is tripping it up.

  • Mo
    Avatar
    Community Member
    509 Posts

    Re: Dashboard Module Link to this post

    Ok, I tried to install DataObjectManager from the trunk. It didn't flag up the error you mentioned.

    It didn't seem to like loading the Javascript/CSS though, so I only got the basic HTML for the Table and Form :s

  • UncleCheese
    Avatar
    4085 Posts

    Re: Dashboard Module Link to this post

    You gotta make sure you change the folder from dataobject_manager_r123213 to just "dataobject_manager"

  • Mo
    Avatar
    Community Member
    509 Posts

    Re: Dashboard Module Link to this post

    Strange, it works fine for me.

    Are you using SS 2.3.3?

    Are you using Dashboard from the trunk?

    Seems very odd :s

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Dashboard Module Link to this post

    Lovin' it !!!

    Thanks for the hard work !

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: Dashboard Module Link to this post

    This looks good. Real good actually.

    I'll test it out. A site I want to install this uses UC's DOM, so I'll see what happens when I try getting them to work together.

    Thanks and hopefully this gets maintained. As mentioned, SS really needs something like this.

  • MarcusDalgren
    Avatar
    Community Member
    288 Posts

    Re: Dashboard Module Link to this post

    This seems like an awesome initiative!

    Unfortunately, I can't get it to work . I'm trying to run it on the latest trunk version of SilverStripe and I've tried both the trunk from your SVN and the 0.3 branch.

    In both cases I get [User Warning] Bad class value NULL passed to ClassInfo::ancestry()

    I've tried building and flushing but I still get this error when trying to access the CMS.
    Surfing the rest of my site works.

    If anyone knows how to fix this please let me know, I'm dying to try this module out!

    EDIT
    I just tried the module with my 2.3.2 installation and it works fine there.
    The module looks super, keep up the awesome work!

  • Mo
    Avatar
    Community Member
    509 Posts

    Re: Dashboard Module Link to this post

    Have you tried it with the 2.3.3 tag of Silverstripe from SVN? That is what I am using and I am not getting any issues.

    The trunk of Silverstripe is under quite a bit of development, so it is possible that they might be tweaking something for the next release that might mess this up, I will have to give it a go when I have 5 mins!

    Glad you are enjoying though, this seems to be gaining in interest. It would be cool if 2.4 had a Dashboard out of the box .

    Mo

    15658 Views
Page: 1 2 3 4 5 6 7 8 9 10 11
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.