Jump to:

10847 Posts in 2516 Topics by 1792 members

All other Modules

SilverStripe Forums » All other Modules » USERFORMS - userdefinedpagtype keeps changing back to standard pagetype

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1091 Views
  • africansafari
    Avatar
    Community Member
    30 Posts

    USERFORMS - userdefinedpagtype keeps changing back to standard pagetype Link to this post

    Hi,

    I have installed User Forms, and got it going - it's a great extension!

    However .... the form keeps disppearing on me - this has been happening for the last week, howeve wanted to see any patterns before posting this issue.

    I notice in the admin section the pagetype "change to user defined form" disappears under the 'behaviour' tab, and the page I have set up as a user form reverts back to a pagetype 'page' ... showing the text $userdefinedform - where the form should be.

    To correct this I run a dev/build and change the pagetype back to "change to user defined form" ... and the form reappears. I select the userdefined pagetype, save and publish and the form re-appears.

    I am having to do this every day, first thing when I am at work. The userdefinedform only seems to be holding for about 12 hours ?????

    Very frustrating!!

    Can anyone assist - tell me what do to to correct this anomally ???

    Extra information: I have recently downloaded and installed flickrservice, event_calendar and share this. When I do a dev/build on my site, my site appears to rebuild something/tables - not sure what. I will take a screenshot next time and upload to show you.

    In the meantime, can anyone assist?

    Many thanks. Claire

  • Juanitou
    Avatar
    Community Member
    322 Posts

    Re: USERFORMS - userdefinedpagtype keeps changing back to standard pagetype Link to this post

    Hi Claire,

    There’s maybe a JS conflict (Prototype and jQuery), between event_calendar and userforms, I think I’ve seen a thread on this recently, browse the forum and you’ll eventually find it.

    Sorry for not being more helpful,
    Juan

    EDIT: http://www.silverstripe.org/general-questions/show/269138?start=8#post269671

  • africansafari
    Avatar
    Community Member
    30 Posts

    Re: USERFORMS - userdefinedpagtype keeps changing back to standard pagetype Link to this post

    Thanks Juan. Very much appreciated. Have had a look at other thread ... looks life a wee while before fixing. Will try un-installing event_calendar, which I am not using at the moment, and see if this fixes the problem

  • africansafari
    Avatar
    Community Member
    30 Posts

    Re: USERFORMS - userdefinedpagtype keeps changing back to standard pagetype Link to this post

    As a follow-up ... in case anyone else is having a similar problem. I have un-installed event_calender, but still not fixed. I am now going to uninstall flickr and sharethis service and see if this makes a difference. Will keep you posted!

  • africansafari
    Avatar
    Community Member
    30 Posts

    Re: USERFORMS - userdefinedpagtype keeps changing back to standard pagetype Link to this post

    I un-installed the flickr and sharethis modules yesterday .... and today .... my userforms are still showing .... wahoo!!!

    At the moment I would rather have userforms than the other modules I have un-installed .... until a new release of userforms is out as per http://www.silverstripe.org/general-questions/show/269138?start=8#post269671

    1091 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.