Jump to:

10979 Posts in 2722 Topics by 1815 members

All other Modules

SilverStripe Forums » All other Modules » Script Error in IE6 and IE7 at photo gallery

Discuss all other Modules here.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Page: 1
Go to End
Author Topic: 1791 Views
  • richardus
    Avatar
    Community Member
    6 Posts

    Script Error in IE6 and IE7 at photo gallery Link to this post

    Hi all,

    Can You help me please? In my photo gallery IE6 and IE7 display script error message (in attach file)

    Url address: www.selec.sk/vitajte-v-na-ej-rodnej-obci-vitajte-v-selci/

    Thanks,

    Richard

    Attached Files
  • Kinkykoder
    Avatar
    Community Member
    8 Posts

    Re: Script Error in IE6 and IE7 at photo gallery Link to this post

    Hi there,

    I am getting the same problem.

    Each time the page / thumbnails have loaded I get:

    > Error: 'Behaviour' is undefined

    If I click a thumbnail, I get:

    > Error: Invalid argument.

    I'm on SS 2.3.3 and Gallery 0.2.3.

    Safari and Firefox are working fine, it's just IE (8 in this case) with the error. Does anyone know how to fix it please?

    Many thanks
    Andrew

  • Kinkykoder
    Avatar
    Community Member
    8 Posts

    Re: Script Error in IE6 and IE7 at photo gallery Link to this post

    Hi Richard, I notice that on your link, the pop-ups seem to work in IE8. Did you find a fix for it, or is your problem just in IE6 and 7?

    Thanks if you can help!

  • richardus
    Avatar
    Community Member
    6 Posts

    Re: Script Error in IE6 and IE7 at photo gallery Link to this post

    Hi Kinkykoder,

    sorry, but I did not any change. The problem still exists

    Hmmm....

  • UncleCheese
    Avatar
    4085 Posts

    Re: Script Error in IE6 and IE7 at photo gallery Link to this post

    You should try the ImageGallery module.

  • Kinkykoder
    Avatar
    Community Member
    8 Posts

    Re: Script Error in IE6 and IE7 at photo gallery Link to this post

    Hi, thanks - I've been trying to get Image Gallery working all day, but I just can't get importing to work.

    If I click 'Upload Images' and select a file(s), click open, nothing happens.

    If I select a folder to import from existing folder, I get:

    [User Error] Uncaught Exception: Object->__call(): the method 'backlinktracking' does not exist on 'ImageGalleryImage'

    I read several threads concerning the above error, so I downloaded your latest source from your repository for:

    - dataobject_manager
    - image_gallery
    - swfupload

    and did a dev/build?flush=1

    Can you suggest anything I could be doing wrong please?

    Thanks.

    1791 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.