Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Tutorial - Creating Subtemplate

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1219 Views
  • Oz
    Avatar
    1 Post

    Tutorial - Creating Subtemplate Link to this post

    Got to give you Kiwis' your props; this is one fine CMS ....

    Newby question: at the bottom of tutorial 1 there is a section on creating subtemplates: after following the directions a couple of times I found the content no longer renders: the page.ss and homepage.ss are in the template/layout directrory and $layout statement is the template/page.ss. Putting the $content stmt back in template/page.ss of course renders the content without formattng (expected)

    This is a windows install .... any ideas? ....thx

    Cheers
    Oz

    PS And there's to be no discussions about cricket, rugby or gumboots

  • jananton
    Avatar
    3 Posts

    Re: Tutorial - Creating Subtemplate Link to this post

    Hello Oz,

    Hmm, a newby myself, I think you need to do a flush=1 in your cms window before looking at the result of your subclassing. (http://<yoursitename>/admin?flush=1) The new created files layout/Page.ss and layout/HomePage.ss as well as the original Page.ss need te be (re)loaded in the system before taking effect. I use a windows localhost and had the same problem in the beginning.

    Greetings from overcast Amsterdam,

    Jan

    [using XAMPP localhost on Win XP SP2]

    1219 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.