Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » I Hate to Sound Like a Noob...But, I Need Some Installation Help...

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 5026 Views
  • tripod0502
    Avatar
    Community Member
    4 Posts

    I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    ...But, I've set up a database for the SilverStripe CMS and have tried specifying it's location (in sub-domain), user info and name in both the installation page through my browser as well as editing install.php and then uploading with the same result.

    To give you the skinny...I am hosting this particular website through Dreamhost with PHP 5.x and MySQL 5.x.

    I've combed through your site and have tried virtually everything I could find that was related (e.g.- "//" in front of line 77 in install.php...etc.)

    I feel ike I've tried about everything within my (somewhat)limited scope of knowledge and I keep on getting these errors....

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/XXXXX/install.php on line 77

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in /home/home/XXXXX//install.php on line 77

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/home/XXXXX//install.php on line 354

    Warning: mysql_get_server_info() [function.mysql-get-server-info]: A link to the server could not be established in /home/home/XXXXX//install.php on line 354

    I'd really like to give this CMS a try...as it looks like a viable alternative to the CMS we use now...Joomla ;)

    Any and all help would be greatly appreciated! Cheers...and keep up the good work!

  • gakenny
    Avatar
    Community Member
    153 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    Are you getting an error about the version of MySQL running on the server?

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    The error you have there all relates to "Can't connect to local MySQL server ...."

    Are you certain that you have a running MySQL server on your server? What version? Let me know if you want to know how to check your mysql server IS running...

  • tripod0502
    Avatar
    Community Member
    4 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    Thanks for the quick response guys!

    To answer your questions...I am running MySQL - 5.0.24a-standard-log in a sub-domain "mysql.XXXX.XXXX.com" with full administration/creation priviledges granted to the user as I tried in the methods I previously posted.

    I hope this helps...please let me know if there is anything else you might need to help narrow this down.

    I REALLY appreciate all of your help!!!

  • Ingo
    Avatar
    Forum Moderator
    801 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    Perhaps you've got a non-standard socket location? (wild guess)
    You can check this location in your my.conf at the line with "socket=", and confirm that you've got the correct permissions set on this file?

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    Have you got other PHP scripts connecting to the database properly (e.g. phpMyAdmin?)

    You could make your own php file, called mysqltest.php with:

    <? echo mysql_connect ( "host", "username", "password" ); ?>

    See http://php.net/mysql_connect for information on the mysql_connect statement.

    Can you let us know if you get the above working, and then we can see if the issue is with SilverStripe or your MySQL/PHP config

  • tripod0502
    Avatar
    Community Member
    4 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    Again...thanks for your quick response guys!

    I really appreciate all of your help...as I am more of a web designer as opposed to a developer like you guys...I am just usually more concerned with making it look pretty ;)

    To answer your question Sigurd...all of the databases (across many domains are administered through phpMyAdmin.

    It seems as though I'm not having any problems connecting to the database.

    All the other sites that we have are connected to MySQL through the same manner without a hitch.

  • Kimberlymarie
    Avatar
    Community Member
    6 Posts

    Re: I Hate to Sound Like a Noob...But, I Need Some Installation Help... Link to this post

    I hate to pull up an older thread, but this is exactly the same problem I've been having, and can't get anywhere. I'd love to be able to use SS... Got quite a few sites it would be perfect for.

    I, too, am hosted with Dreamhost.

    Tripod0502, or anyone else, gotten SS installed on DH?

    The database does exist and I can connect fine with any other scripts. I also get the thing saying it can't find Apache. Rest assured, it's there!

    5026 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.