Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Speed issues

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2 3 4
Go to End
Author Topic: 9728 Views
  • anders
    Avatar
    Community Member
    2 Posts

    Speed issues Link to this post

    My company is seriously considering using silverstripe. However since we´re nubies we have come across some problems when it comes to website speed/performance.

    Is there some easy steps that we have missed? Some major "don´t do it".

  • marikas
    Avatar
    Community Member
    24 Posts

    Re: Speed issues Link to this post

    Do you mean on the template side of things or db optimization, optimal server config etc?

    If it's the template, we can tell you everything you've done wrong, or right with the site, if you provide us with a link.

    Use this as a start: http://www.websiteoptimization.com/services/analyze/

    Cheers

  • anders
    Avatar
    Community Member
    2 Posts

    Re: Speed issues Link to this post

    Thanks for a quick response! I guess I wasn't so precise in my question. We find Silverstripe kind of slow when we install it "out of the box" using the tutorial skin in Silverstripe 2.2 rc2.

    Is there any way to speed things up? We experince a kind of generic slugishness in page rendering.

  • marikas
    Avatar
    Community Member
    24 Posts

    Re: Speed issues Link to this post

    Hmm... nope sorry, I'm too new to this CMS to know whats going on under the hood. Just isn't my forte. Hopefully someone else here can help.

  • Fuzz10
    Avatar
    Community Member
    786 Posts

    Re: Speed issues Link to this post

    Indeed, SS isn't the fastest of CMS's around. I guess the underlying framework takes its toll on performance. In my opinion it is worth it (read: the cleanliness and structure outweighs the slower performance) , but I can image for some applications (very high throughput sites for example) it's just not suitable.

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: Speed issues Link to this post

    If you have a fairly modern server and running a PHP cache (e.g. php5-xcache) then performance should be fine.

    Do you find your setup considerably slower than http://demo.silverstripe.com/ for instance?

  • Fuzz10
    Avatar
    Community Member
    786 Posts

    Re: Speed issues Link to this post

    >Do you find your setup considerably slower
    >than http://demo.silverstripe.com/ for instance?

    The problem is with your servers being located in NZ (we're talking BIG latency here , 300 to 400 ms pings) , I can't make an honest judgment about that.

    ;-)

  • Anatol
    Avatar
    126 Posts

    Re: Speed issues Link to this post

    Hi,

    I installed XCache today and it made a serious performance leap even on just a development server with virtually no traffic.

    I used this RPM by Jason Litka because I use his yum repository (RHEL/CentOS) to upgrade to the latest PHP/MySQL/Apache versions.

    Cheers!
    Anatol

    9728 Views
Page: 1 2 3 4
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.