Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » 2.2 upgrade - login form missing

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1514 Views
  • binarysavant
    Avatar
    Community Member
    1 Post

    2.2 upgrade - login form missing Link to this post

    After upgrading to 2.2 i cant login to the CMS anymore.

    The login form is missing, no errors are reported.

    I just says
    "Please choose an authentication method and enter your credentials to access the CMS.".

    Any ideas?

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: 2.2 upgrade - login form missing Link to this post

    Does the form show when you View-Source?
    I.e. is it a problem of CSS or HTML ?

    You may need to refresh the silverstrpie (flush=1) or browser CSS cache.

  • froburg
    Avatar
    Community Member
    8 Posts

    Re: 2.2 upgrade - login form missing Link to this post

    As per http://doc.silverstripe.com/doku.php?id=upgrading

    Check that you have a Layout/Page.ss file for your site, or alternately have a Security_login.ss template.

    Your template file needs a $Form variable for it to work. This is where the login form gets included.

    Without either of these, the Security/login form will be blank.

    1514 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.