Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Installation faild ... see error code

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2017 Views
  • DirtyGrisu
    Avatar
    Community Member
    3 Posts

    Installation faild ... see error code Link to this post

    Hello,
    my installation fail with folloed error:
    -----------------------------------------------------------------------------------------
    -----------------------------------------------------------------------------------------
    Setting up 'mysite/_config.php'...
    Setting up /webs/newweb.og-holzheim.de/mysite/_config.php
    Setting up '.htaccess' file...
    Setting up /webs/newweb.og-holzheim.de/.htaccess
    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /webs/newweb.og-holzheim.de/sapphire/core/SSViewer.php on line 304

    Building database schema...
    Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /webs/newweb.og-holzheim.de/sapphire/dev/Log.php on line 2

    Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='.') in /webs/newweb.og-holzheim.de/sapphire/dev/Log.php on line 2
    -----------------------------------------------------------------------------------------
    -----------------------------------------------------------------------------------------

    What can i do to correct the problem.

  • emil.blume
    Avatar
    Community Member
    11 Posts

    Re: Installation faild ... see error code Link to this post

    Sorry for others but this one I will answer in german...

    Hallo,

    das liegt an dem slash

    Setting up /webs/newweb.og-holzheim.de/mysite/_config.php

    die Zeile sollte lauten

    Setting up webs/newweb.og-holzheim.de/mysite/_config.php

    zZ kann ich aber nicht sagen in wie weit man über die Installation Einfluß darauf hat. Ggf. setzt der Server den Pfad auch um...
    Handelt es sich um eine Windows Maschine?

    Nachtrag: An dem oben gezeigten slash liegt das auch nicht. Es ist jedenfalls ein Problem mit Pfaden und einem Slash. Irgendetwas wird in ihrem Dateisystem anders umgesetzt als auf den meisten anderen Webhosts.

    Evtl. werden Dateien oder Verzeichnisse unter dem Benuzter root angelegten sollten aber einen anderen Besitzer haben, oder ähnliches.

  • DirtyGrisu
    Avatar
    Community Member
    3 Posts

    Re: Installation faild ... see error code Link to this post

    Hallo Danke für die rasche Antwort.
    Ich weiß, dass es kein Windows-Server ist.
    Der Server steht bei unserem Provider und ist wahrscheinlich mit einem Debian-Linux, PHP und MySQL ausgestattet.
    Mehr kann ich so nicht sagen - ich habe aber den direkten Draht zu den dortigen Admins.
    Was kann/soll ich denen sagen, was sie tun sollen, dass es funktionieren könnte ??

    Ich selbst bin "leider" nur ein kleiner Windows Guru - Admin - o.ä. und schlage mich mit MS-Server rum.
    Deshalb habe ich Linux, PHP und MySQL noch nicht gebraucht...also auch keine Erfahrung/Wissen.

    Danke nochmals für die Hilfe
    Gruß
    DirtyGrisu

  • emil.blume
    Avatar
    Community Member
    11 Posts

    Re: Installation faild ... see error code Link to this post

    hmmm etwas seltsam das ganze

    Ich habe grade in einer frischen 2.4 Installation nachgeguckt.

    in der Datei /sapphire/dev/Log.php wird tatsächliche eine Zend/Log.php aufgerufen:

    require_once 'Zend/Log.php';

    diese Datei gibt es allerdings nicht. Vorhanden ist allerdings ZendLog.php
    also vielleicht versuchen die erste Zeile in /sapphire/dev/Log.php ändern in

    require_once 'ZendLog.php';

    und dann mal versuchen.

    Allerdings sagt die Fehlermeldung
    "Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /webs/newweb.og-holzheim.de/sapphire/core/SSViewer.php on line 304 "

    Also hat sich vorher schon ein Backslash eingeschlichen, der nicht da hingehört, wo er steht.

  • DirtyGrisu
    Avatar
    Community Member
    3 Posts

    Re: Installation faild ... see error code Link to this post

    ...also, ich hab das nun versucht,
    dann meckert er an, dass in der ZendLog.php das gleiche fehlen würde.
    Dann habe ich auch da die Zeile geändert und bekomme nun einen weiteren Fehler:

    ------------------------------------------------------
    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /webs/newweb.og-holzheim.de/sapphire/core/SSViewer.php on line 304
    # Building database schema...

    Fatal error: Class 'Zend_Log' not found in /webs/newweb.og-holzheim.de/sapphire/dev/ZendLog.php on line 14
    ------------------------------------------------------
    Klar, dass die Warnung immer noch kommt, aber jetzt fehlt halt eine Class ....

    Also ich komm nicht weiter ....

    2017 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.