Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » SS + Prototype version.

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1004 Views
  • dio5
    Avatar
    Community Member
    501 Posts

    SS + Prototype version. Link to this post

    SS uses Prototype.

    When using validation, SS includes prototype. But this version is old. (1.4!)

    To keep the total size of files small, I would like to use the library that gets included by SS.
    But I really want at least 1.5 and I noticed that there already is a prototype15.js file.

    As it is quite ridiculous for me to include 1.6 on top of the version that SS uses for validation, I want to know if there are any plans for upgrading this.. ( even only on the frontend side).

    If I have to add the newer version as an 'extra' I could just as well use YUI, which I like a lot more. But then I would miss the whole point of keeping total size small.

    grt

  • Willr
    Avatar
    Forum Moderator
    5489 Posts

    Re: SS + Prototype version. Link to this post

    I think the reason we havent upgraded is that while we use 1.4 its pretty customized to SilverStripes needs and its going to fun times upgrading to 1.6+ so its one of those things no one wants to try I think that prototype15 is probably someone slowly porting SS features or testing it at least. I remeber one of the GSOC students wanted to push to 1.5 so maybe someones started using it for something?

  • dio5
    Avatar
    Community Member
    501 Posts

    Re: SS + Prototype version. Link to this post

    well, you got to upgrade once, no?

    Even only on the frontend side.

    1004 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.