Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » A couple of problems with silverstripe - Languages

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1755 Views
  • Anselmo
    Avatar
    6 Posts

    A couple of problems with silverstripe - Languages Link to this post

    Hi,

    I'm having some problems with languages:

    1- I enabled in18 as in the docs and set the main language to pt, like this:
    i18n::enable();
    i18n::set_default_lang('pt_PT');
    Then in the cms I created a new trasnlation (en), and all gone as expected, the dropdown with the language switcher appears at the bottom of the site tree. But when I edit a page or go to other section of the cms and then comeback to editing, the language switcher disappears.

    2 - When I allow comments on pages, the output in the site shows me the form for comments in english, although the main language I set is (pt_PT). Is it translatable? Am I doing something wrong? Can I have the site just in one language, for example, portuguese?

    3- I posted some comments to test, and the time that appears on comments has one hour plus, but inside the cms it is correct.

    I hope I'm not asking to much.

    Thanks in advance

  • rbarreiros
    Avatar
    Community Member
    21 Posts

    Re: A couple of problems with silverstripe - Languages Link to this post

    Hello Anselmo,

    Those strings are currently translateable (meaning the translation support has been added) in the SVN version (development), just waiting for the translate.silverstripe.org to be updated with more strings to translate, when it does, you will be able to update your translations there to get always the latest of the latest without downloading the development version.

    I'm doing the pt_PT translation and adding a few more translation strings, if you need any help, or find something wrong regarding the translations into Portuguese please let me know.

    Best regards,

  • pjssms
    Avatar
    Community Member
    49 Posts

    Re: A couple of problems with silverstripe - Languages Link to this post

    Hello,

    I have tried the page about i18 and my page just went blank.

    Have you managed to have the site in more than one language ?.

    How is the demo done ? I was expecting to have one translation tab like that ...

    Thank you,

    Paulo Santos

    1755 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.