Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Installation Problem

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 2347 Views
  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Installation Problem Link to this post

    Hi !

    Looks like a promising project !!

    Unfortunately I ran into a problem during the install. Could this have anything to do with my mass vhosts setup in apache ?

    Thanks!

    gr,
    Lars

    ----------------------------------------------
    I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation
    # Creating 'assets' folder...
    # Creating 'mysite/_config.php'...
    # Creating '.htaccess' file...
    # Building database schema...

    Fatal error: Cannot redeclare property static public LeftAndMain::$tree_class in class AssetAdmin in /cms/code/AssetAdmin.php on line 7
    ----------------------------------------------

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Installation Problem Link to this post

    Argh, unfortunately I still have the same problem.

    Am I forgetting something ?

    My specs :
    PHP 5.03
    Apache 2.0.53
    MySQL 4.11
    Mass Vhosts is enabled in Apache

  • EvilSeph
    Avatar
    Community Member
    3 Posts

    Re: Installation Problem Link to this post

    Hi there,

    I need help with this too.

    I can install SilverStripe fine on a local test server, but on a remote server this error comes up:
    Installing SilverStripe...

    I am now running through the installation steps (this should take about 30 seconds)

    If you receive a fatal error, refresh this page to continue the installation
    # Creating 'assets' folder...
    # Creating 'mysite/_config.php'...
    # Creating '.htaccess' file...
    # Building database schema...

    Fatal error: Cannot redeclare property static public LeftAndMain::$tree_class in class AssetAdmin in /www/devden.net/cms/code/AssetAdmin.php on line 7

    SilverStripe Version 2.0.0
    MySQL 4.1.9
    PHP version 5.0.3
    Apache 1.3.33

    Any help would be greatly appreciated.

  • Sigurd
    Avatar
    Forum Moderator
    628 Posts

    Re: Installation Problem Link to this post

    I wonder if this is due to the early version of PHP5.
    I was debugging something on PHP 5.0.5 which was doing my head in last night...

  • EvilSeph
    Avatar
    Community Member
    3 Posts

    Re: Installation Problem Link to this post

    Yea, it looks like SilverStripe is not compatible with the PHP version I have on the remote server.

    I have (on my local server):
    SilverStripe Version 2.0.0 (and SilverStripe Version 2.0.1rc2)
    PHP Version 5.2.1
    Apache 2.2.4
    My SQL 5.0.22

    Edit: SilverStripe v2.01rc2 does not work with the PHP version I have on the remote server either.

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Installation Problem Link to this post

    Okay, it took a while. But I solved it.

    Problem is that we run a Mass Vhost setup on our development server (Apache). Combining mod-rewrite with mass vhost is impossible. So in order to get Silverstream running you need to create a "regular" Vhost in Apache.

    A bit silly , but it took me a while to figure this out ... ;-)

    Got it up and running now. Looks really promising !

    2347 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.