Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Can't upload images

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2 3 4 5 6 7 8 9
Go to End
Author Topic: 394638 Views
  • phinel
    Avatar
    Community Member
    16 Posts

    Re: Can't upload images Link to this post

    Hello everybody

    I've donwloaded the newest version of SWFUpload (Version 2) from http://www.swfupload.org/node/1/release and replaced the file
    jsparty/SWFUpload/SWFUpload.swf
    with this one
    swfupload/FlashDevelop/Flash9/swfupload_f9.swf
    from the archive

    And now, it works on my server.

    It would be nice if somebody could try this on his website and post here, if this works for him, too.

    PS: Don't forget to clear the cache...

    phinel

  • mbellino
    Avatar
    Community Member
    32 Posts

    Re: Can't upload images Link to this post

    Hello Phinel

    Good hint. I did it too.

    I've donwloaded the newest version of SWFUpload (Version 2.0.1) and replaced the file jsparty/SWFUpload/SWFUpload.swf with this one
    swfupload/FlashDevelop/Flash9/swfupload_f9.swf from from the archive.

    With ?flush=1 I've also flushed the cache and empty my local browser cache.

    No success

    Cheerio

    Mario

  • phinel
    Avatar
    Community Member
    16 Posts

    Re: Can't upload images Link to this post

    Strange

    Have you already changed the permissions?

    I gave the folder "assets" and all his subfolders the permission 777. The same for the folder "jsparty/SWFUpload" and "cms/javascript".

    phinel

  • mbellino
    Avatar
    Community Member
    32 Posts

    Re: Can't upload images Link to this post

    Hi Phinel

    Yes. 777 for "assets" and subfolders.
    Also give it a try with 777 for jsparty and cms.

    No luck.

    As I mentioned in a post before, the request is blocked by the provider.
    I will contact him and ask for the new logfile.

    Cheerio

  • phinel
    Avatar
    Community Member
    16 Posts

    Re: Can't upload images Link to this post

    I've already contacted my provider and they told me that the apache module mod_security blocks this script. This could come from an error in the adobe flash player.

    I found a site where somebody disabled mod_security with an entry in the .htaccess file:

    SecFilterEngine Off
    SecFilterScanPOST Off

    When i add this two lines in my .htaccess file, everything works fine. But i would leave this module enabled.

    Have you already tried this change?

  • mbellino
    Avatar
    Community Member
    32 Posts

    Re: Can't upload images Link to this post

    When I set the options in the .htaccess I get an Apache "Internal Server Error".
    Unfortunately it doesn't work with my provider, however nice hint.

    Thanks

  • Carel
    Avatar
    Community Member
    3 Posts

    Re: Can't upload images Link to this post

    Cant upload images on local server. XP SP2, freshly installed WAMP and Silverstripe v2.2.1
    If I use windows explorer to paste images to the assets folder, they DO show in "Files & Images" tab. It is just the CMS uploader that does not work for me. Does not upload in IE either.

    Carel

  • quicked
    Avatar
    Community Member
    32 Posts

    Re: Can't upload images Link to this post

    and you have write permissions on the folder?

    394638 Views
Page: 1 2 3 4 5 6 7 8 9
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.