Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » IFrame Module

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 7374 Views
  • haygoodg
    Avatar
    Community Member
    2 Posts

    IFrame Module Link to this post

    I created a little module to enable IFrames within the CMS. So instead of entering content for a Page, you just provide a Remote URL, and it will be embedded within your site.

    You can get it here: http://devwisdom.googlecode.com/files/iframe-0.1.zip

    All feedback welcome!

  • mbellino
    Avatar
    Community Member
    32 Posts

    Re: IFrame Module Link to this post

    Hello Haygoodg

    Nice work!!

    I didn't try it out yet, but I appreciate every single idea, module and widget that let grow the features from SS.

    Give rein to your ideas

    Have a nice day

    Cheerio
    Mario

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: IFrame Module Link to this post

    Hi,

    Just used your module , great work. There is one hitch though, after installing the module, by default it fills the width and height with pixel values (e.g. 600px).. That does not work, one has to change these values to integer values (e.g. 600) in order for the them to do anything.

  • asfahaan
    Avatar
    Community Member
    6 Posts

    Re: IFrame Module Link to this post

    W0rks really well.

    Much appreciated!!

    Yep noticed the px glitch.

  • Jethro
    Avatar
    5 Posts

    Re: IFrame Module Link to this post

    I tried the iframe. It seems to load ok when I did /db/build. When I go to the CMS I can not find the icon. It tried ?flush=1 and dumped my browser cache and still no icon. I know this sounds like a really dumb question but here goes, where should I see the button/icon for the iframe?

    Best,

    Jethro

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: IFrame Module Link to this post

    You are not supposed to see an icon. Instead, a new page type will be selectable in the "create" dropdown.

    Good luck !

  • Jethro
    Avatar
    5 Posts

    Re: IFrame Module Link to this post

    Fuzz10-

    Thanks for your reply. I finally found it last night and didn't get back on here to remove my question. Mondays can drive you nuts.

    Thanks again,
    Jeff

  • dancrew32
    Avatar
    Community Member
    15 Posts

    Re: IFrame Module Link to this post

    anyone having trouble making this work again in 2.2.2 rc4?

    Edit: Nevermind, I just deleted it and reinstalled it completely.. it's fine again. Sorry about that.

    7374 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.