Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Bug: Extreme slowdown on a form-page with a lot of submissions.

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1259 Views
  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Bug: Extreme slowdown on a form-page with a lot of submissions. Link to this post

    Can someone confirm that (user generated) form-pages which already received a lot of submissions (couple of hundred) take an excruciating long time to load up in the back-end (when editing) ?

  • Ingo
    Avatar
    Forum Moderator
    801 Posts

    Re: Bug: Extreme slowdown on a form-page with a lot of submissions. Link to this post

    how long does it take you on which system specs (client/server)?
    do you think this is caused by javascript or actual server-rendering-time? (use firebug to time your request). i've had a quick look at UserDefinedForm.php, no javascript being applied there, and just the usual relation getting.
    implementing paging could help of course....

  • Fuzz10
    Avatar
    Community Member
    787 Posts

    Re: Bug: Extreme slowdown on a form-page with a lot of submissions. Link to this post

    Thanks for your reply Ingo.

    Seems to me it's a purely server-side related issue. The hardware is not in issue in this case (8 processor big ass server, fast as hell). I just deleted a lot of submissions and now it's working again. It's probably just a matter of the system returning _all_ submissions instead of a subset.

    1259 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.