Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Embargo / Expiry module not working?

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 4748 Views
  • superautomatic
    Avatar
    Community Member
    53 Posts

    Embargo / Expiry module not working? Link to this post

    Hi, I was just trying the Embargo / Expiry module, but I can't get it to work. As soon as I save/publish a timed page, it's online, even if the embargo date is set to sometime in the future. (Tested on v 2.2.1). Any thoughts?

  • simon_w
    Avatar
    Forum Moderator
    473 Posts

    Re: Embargo / Expiry module not working? Link to this post

    Looking into it now.

    And the forum module really needs a way to subscribe to threads without posting.

  • simon_w
    Avatar
    Forum Moderator
    473 Posts

    Re: Embargo / Expiry module not working? Link to this post

    Figured it out.

    If you're logged in as an Admin, or on the Stage site, you can always see the page.

    Log out and you shouldn't be able to see the page.

  • superautomatic
    Avatar
    Community Member
    53 Posts

    Re: Embargo / Expiry module not working? Link to this post

    Sweet and simple. Should've tried that of course...
    Thanks for the quick reply!

  • ian
    Avatar
    Community Member
    7 Posts

    Re: Embargo / Expiry module not working? Link to this post

    You should probably put a note in the readme/install doc explaining the admin-sees-all effect.

  • wailing
    Avatar
    Community Member
    1 Post

    Re: Embargo / Expiry module not working? Link to this post

    does embargo / expire module work in a multi language website ? this module doesnt seem to work in multi languange environment. I have been logged out as admin and the environment is set to "live" but the expired page is always visible in multi language website. do you have any idea what the solution is to make embargo / expire module work in multilanguage website ?

    sorry about my bad english ;) i hope you understand my issue.

  • cerelac
    Avatar
    Community Member
    34 Posts

    Re: Embargo / Expiry module not working? Link to this post

    Hi everyone.
    I've tried to use this module but I can't get this to work.
    When I set a embargo and expiry time, I can see the page if I'm logged on as an administrator as simon_w said.
    But, if I'm logged out, when the time comes, nothing happens. The page is not published, neither is removed when it expires.

    Has somebody had this problem already?
    Is there any solution to this?

  • simon_w
    Avatar
    Forum Moderator
    473 Posts

    Re: Embargo / Expiry module not working? Link to this post

    Which version of the module are you running? And on which version of SS?

    If you're using 0.2, you must have 2.2.2.
    If you're using 0.1 and the decorator, you must be running 2.2.2, though I recommend updating to 0.2.

    4748 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.