Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Used recommended web host SERVAGE but cant install Silverstripe

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 3232 Views
  • dille4
    Avatar
    Community Member
    14 Posts

    Used recommended web host SERVAGE but cant install Silverstripe Link to this post

    Downloaded latest version of Silverstripe (2.2.1), copied all files into my /www folder on SERVAGE Web Host and set everthing up until I got green light from the installer. (see allgood4.jpg and allgood5.jpg). I have chosen "Empty template" and started install ...

    The first error I get (message appears only for a sec) is that "mod_rewrite" is not working, although the installer (allgood4.jpg) tells "mod_rewrite" is enabled.

    Site gets refreshed and another message pops up (error4.JPG) telling me that I have to set up "mod_rewrite" and "AllowOverride". The problem is I'm using SERVAGE as a web host and can't setup http.conf.

    After I kept going with the installer it ends where it all ends - with a white page and error 404.

    I know there are so many threads about the problem here but I couldn't find one appropriate solution. I have chosen SERVAGE as a web host because it was recommended. I thought I don't have to worry about altering ".htaccess" and memory issues ... Hmmm!

    At last here the ".htaccess" I have tried as well (but nothing)

    ### SILVERSTRIPE START ###

    RewriteEngine On

    RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

    php_value memory_limit 64M
    php_value register_globals off
    php_flag magic_quotes_gpc on
    php_flag display_errors on

    ### SILVERSTRIPE END ###

    PS: PHP_Safemode is off ...

    I hope someone out there can give me a tip.

    Cheers,
    Tom

  • dille4
    Avatar
    Community Member
    14 Posts

    Re: Used recommended web host SERVAGE but cant install Silverstripe Link to this post

    It's getting strange now ...

    After giving up installing Silverstripe 2.2.1 on SERVAGE I got another domain on Digital Space. Uploaded a complete fresh version on the host, set everthing up until I got green lights on every check.

    As I expected I got exactly the same error messages as I got on SERVAGE. ("mod_rewrite" and "AllowOverride") and again I can't change anything as I'm not a admin of this host, only a user.

    The funny thing is this time I didn't get the 404 error but instead the CMS login screen popped up. I typed in my Email (admin) and Password (password) as I setup before. Now the system doesn't except the login ...

    What's wrong? Did I get a buggy install routine or is it just me ... I'm very confused!!!!

  • Tim
    Avatar
    Core Development Team
    201 Posts

    Re: Used recommended web host SERVAGE but cant install Silverstripe Link to this post

    not sure what the issue is here, but you may want to look at the list of hosts which are known to work

    http://doc.silverstripe.com/doku.php?id=suggested-web-hosts

  • dille4
    Avatar
    Community Member
    14 Posts

    Re: Used recommended web host SERVAGE but cant install Silverstripe Link to this post

    Hi Tim,

    Servage.net is in the list of the recommended hosts. However, the Servage support team and I solved the problem. A line in the ".htaccess" file was missing: "AllowOverride All"

    Here the content of the file:

    AllowOverride All
    ### SILVERSTRIPE START ###

    RewriteEngine On
    RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$
    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

    php_value memory_limit 64M
    php_value register_globals off
    php_flag magic_quotes_gpc on
    php_flag display_errors on

    ### SILVERSTRIPE END ###

    The support team explained that it can take up to 3 hours before the server checks all ".htaccess" files in the upper subdirectories. After 3 hours I got an "Internal Server Error" 500. It seemed ".htaccess" has overwritten few ".htaccess" files in the upper subdirectories but not all. After that the line "AllowOverride All" wasn't compatible anymore and I deleted the line. I started the install routine without a single error.

  • LarcenIII
    Avatar
    Community Member
    8 Posts

    Re: Used recommended web host SERVAGE but cant install Silverstripe Link to this post

    I get that error 500 on all my SS sites hosted on godaddy.
    I had to comment out a line that send a content-type header.

    Only happens on refresh, with firefox...

    3232 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.