Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Install problem (php5) *SOLVED*

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 5219 Views
  • ODB
    Avatar
    Community Member
    5 Posts

    Install problem (php5) *SOLVED* Link to this post

    Hi there

    I have been hacking through the install, solving various problems and now this:

    My host normally runs php4 and tells me I should add the following line to enable php5 in the .htaccess file:

    AddHandler application/x-httpd-php5 .php

    At the moment it is the ONLY thing I am adding (and indeed the only line present in .htaccess). The requirements tell me I should use php5 so I add the line in and hit the 'Re-chack requirements' button.

    The site hangs after several minutes with a '500 Internal Server Error'.

    If I remove the entry in .htaccess, it works fine (or rather, the installer page reappears). Any ideas? (I don't have access to the httpd.conf file, it's a shared hosting account).

  • simon_w
    Avatar
    Forum Moderator
    467 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    Is there anything in an error log somewhere?

  • ODB
    Avatar
    Community Member
    5 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    Afraid not. The error_log in the root comes up with nothing. Does Silverstripe log anything anywhere?

  • i.jacobs
    Avatar
    Community Member
    3 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    Hey,

    Seems like I'm not the only one having Problems with PHP5 while installing SilverStripe. My Webhoster (1und1) supports PHP4 and 5, but 5 only with file-extension *.php5. Is there any chance to easily fix this than manually renaming every php file and editing source-code?

    Thanks in advance

    Ivo

  • ODB
    Avatar
    Community Member
    5 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    Is there no '.htaccess' file you can change?

  • ODB
    Avatar
    Community Member
    5 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    With regard to my original issue, this site was a test site with no url forwarded to it (yet), so I was using the host's resolved server name with the account name '/~myaccname' appended to the end to access it. This appears to have been the issue in the reply to the support ticket I submitted:

    "php5 will not function correctly when using the userdir extension to preview the site. This is due to a limitation on how this module works, and it cannot be avoided. You will need some sort of domain pointing to the account in order to preview php5 sites. You can, for example, park a sub domain on the primary domain and use that subdomain for testing."

    I have parked a spare domain on the webspace and it seems quite happy now, so this one is solved.

  • ODB
    Avatar
    Community Member
    5 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    @ i.jacobs

    I saw on another cms this line to use in 1and1 .htaccess files:
    'AddType x-mapp-php5 .php'

    Hope that helps.

  • i.jacobs
    Avatar
    Community Member
    3 Posts

    Re: Install problem (php5) *SOLVED* Link to this post

    it works! thanks for the hint.

    i added

    AddType x-mapp-php5 .php

    AddHandler x-mapp-php5 .php


    to .htaccess in the root-directory.

    5219 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.