Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » more issues with mod_rewrite... help!

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1020 Views
  • Creative Access
    Avatar
    Community Member
    4 Posts

    more issues with mod_rewrite... help! Link to this post

    Hi all,

    I know this is an old issue but I have installed a copy of SS on shared hosting with no http_config access and I cant get past the mod_rewrite issue;

    Server software   I can't tell what webserver you are running. Without Apache I can't tell if mod_rewrite is enabled.

    mod_rewrite enabled   I can't tell whether mod_rewrite is running. You may need to configure a rewriting rule yourself.

    I have called the hosting company who said add some rewrite rules to the .htaccess file so I went through all the past suggestions in the SS forum and nothing has worked!

    This is what I have ended up with;

    # Standard SilverStripe HTACCESS file

    RewriteEngine On

    RewriteCond %{REQUEST_URI} ^(.*)$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule .* /sapphire/main.php?url=%1&%{QUERY_STRING} [L]

    but to be fair I have tried all the suggestions so far and to be honest as the dite is for a client things are getting serious.

    Can anyone help?

    Thanks and best wishes in advance

    Derek

  • Creative Access
    Avatar
    Community Member
    4 Posts

    Re: more issues with mod_rewrite... help! Link to this post

    Sorry to push it but does anyone have any thoughts?

    It's a real shame if i cant get this sorted by tomorrow because I will have to use another CMS which I really don't want to do!

    Cheers guys.

    1020 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.