Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Cannot add members

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 4149 Views
  • raphael
    Avatar
    Community Member
    3 Posts

    Cannot add members Link to this post

    I just installed Silverstripe with the default template on linux with apache/php5.2. Everything is fine up to now except the Add member panel doesn't work (admin/Security/).

    Fatal error: Call to a member function hasMethod() on a non-object in /var/www/..../sapphire/forms/Form.php on line 540

    It looks oddly similar to ticket http://open.silverstripe.com/ticket/2044

    This is clearly a showstopper, as I can't add any user...

    Raphaël

    silverstripe-v2.2.1 php installer
    Apache/2.2.3 (Debian) DAV/2 SVN/1.4.2 mod_fastcgi/2.4.2 PHP/5.2.0-8+etch10 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_vhost_hash_alias/1.0 mod_perl/2.0.2 Perl/v5.8.8

  • tschunde
    Avatar
    Community Member
    3 Posts

    Re: Cannot add members Link to this post

    Hi I get that same error with 1&1 homepage pro :/

    Is it solved somehow?

  • raphael
    Avatar
    Community Member
    3 Posts

    Re: Cannot add members Link to this post

    I don't know wether it is solved or not, but the workaround is to create users using the inline form, then clicking on the edit button and add a password.

  • Dennis
    Avatar
    Community Member
    7 Posts

    Re: Cannot add members Link to this post

    I ran into the same problem...

    Workaround goes great - right up until I hit the 'edit' button.

    The little window pops up with the following error msg:

    Fatal error: Call to a member function id() on a non-object in /usr/local~...~/forum/code/ForumRole.php on line 220

    Alas, no passwords...

    I'm running 2.2.1 at the moment. I tried 2.2.2 yesterday, but ran into too many problems and my 'drop-dead' date on this proof of concept project is about 1/2 hr from now... I'll likely try 2.2.2 again if this project gets off the ground.

  • Sean
    Avatar
    Forum Moderator
    921 Posts

    Re: Cannot add members Link to this post

    Please put a note on that ticket that you're experiencing the same problem.

    Change the version to 2.2.2 so it's recognised as a 2.2.2 bug.

    Cheers

    Sean

    4149 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.