Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Images Show Up Compressed

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 109383 Views
  • pdpjeopardy
    Avatar
    Community Member
    1 Post

    Images Show Up Compressed Link to this post

    Hi all! I'm neew to the forums but i've been using silver stripe for a couple monthes now. I have a few questions if anyone can help:

    When I upload an image via the admin upload page, everything is fine, the image looks good, etc. But when I go to place it in a page, the image somehow gets dithered like it's filesize and quality got compressed or something. The images i'm using are jpegs and gifs. Is there anyway to keep the image quality the same?

    And one last question, wheres the line of code located that allows you to see the acrobat, word, excel, zip icons when you post a link to download one of those. I notice those icons disappear when you change template and whatnot.

    Any help would be appreciated!

    Thanks!

  • Willr
    Avatar
    Forum Moderator
    5462 Posts

    Re: Images Show Up Compressed Link to this post

    "And one last question, wheres the line of code located that allows you to see the acrobat, word, excel, zip icons when you post a link to download one of those. I notice those icons disappear when you change template and whatnot. "
    --

    The CSS is in blackcandy/css/typography.css and the images are in images/icons/ or something like that.

    If you just upload and then insert a image it shouldn't look too bad. Have you edited the image at all? Resizing and Resaving the image (if you are using the image editor) will result in a lost of quality.

  • Delphinus
    Avatar
    Community Member
    22 Posts

    Re: Images Show Up Compressed Link to this post

    I too would like the ability to tell SS not to reduce the image quality. I have found a hack over at http://www.silverstripe.com/site-builders-forum/flat/28159 but editing GD.php would need to be done every SS upgrade... A cleaner solution would be handy.

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: Images Show Up Compressed Link to this post

    I've edited the gd.php file and set the quality to 100 for testing purposes, and the image still shows up compressed.

    The original image is 62kb and looks fine after I upload it. I then insert the image into the content area via tiny_mce and the image shows up VERY compressed with a file size of 19kb.

    Has this worked for anybody? Is there anything else I can try? This is becoming a big problem and I need a fix.

  • Delphinus
    Avatar
    Community Member
    22 Posts

    Re: Images Show Up Compressed Link to this post

    I can confirm that it worked for me with a setting of 90. Have you tried uploading a new image after making the change?

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: Images Show Up Compressed Link to this post

    Hmmm thanks for the feedback.

    I've reuploaded the gd.php file many times, trying both 90 and 100 with the exact same result in the image. I've deleted the image and tried reuploading it many times, but still nothing. The original is fine, it's just when I insert it into the content area of a page it becomes resampled, therefore compressed.

    I thought it was a cache issue, but I've disabled the cache, closed the browser etc and still nothing.

    I guess I'll keep digging and see what I can find. Sigh. 62kb to 19kb is a HUGE compression, so you can imagine how bad the image looks.

  • Delphinus
    Avatar
    Community Member
    22 Posts

    Re: Images Show Up Compressed Link to this post

    But have you uploaded a *new* image one that you have never uploaded before?

  • Liam
    Avatar
    Community Member
    470 Posts

    Re: Images Show Up Compressed Link to this post

    Yup, just tried one now and another problem I found.

    I tried inserting the image I use in the header, so I could compare the two on screen. The image is 662px, and when I uploaded it and inserted it into the content area, it resized it to 600px. Nowhere in the template am I resizing the image, so is this normal?

    The originally image I tested wasn't resized, because it was a smaller image, but I'm curious as to why I'm losing 42px in ratio.

    I also tried deleting the images in the cache folder, and also flushing the image cache by /images/flush but there was nothing to update. Figured it was worth a shot.

    109383 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.