Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Fatal error when installing ecommerce module

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 1011 Views
  • JonathanParker
    Avatar
    Community Member
    37 Posts

    Fatal error when installing ecommerce module Link to this post

    I keep getting the following fatal error when I do a db build to install the ecommerce module.

    Fatal error: Declaration of Order_Item::__construct() must be compatible with that of DataObjectInterface::__construct() in C:\wamp\www\dabnis\ecommerce\code\Order.php on line 1107

    Has anybody got any suggestions?

    Regards.

    Jonathan

  • JonathanParker
    Avatar
    Community Member
    37 Posts

    Re: Fatal error when installing ecommerce module Link to this post

    The problem was resolved by downloading the latest ecommerce module build & re-installing the ecommerce module. I did get a further error, but that was cured by replacing the short tag '<?' with standard tag '<?php' within one of the files.

    Thanks to the guys on the IRC chat channel for their help in with this one.

    Jonathan.

    1011 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.