Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Integration Google Analytics Code

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1
Go to End
Author Topic: 3918 Views
  • jensmoewes
    Avatar
    Community Member
    7 Posts

    Integration Google Analytics Code Link to this post

    Hi,
    i pasted the google analytics code in the page.ss file of the theme i use, but don´t receive any
    traffic in my google analytics account, even though it says it receives the data? any hints why that is the case or do i need to put it somewhere else? I put it just before the last </body> in the pages.ss.

    Thanks and regards,
    Jens

  • Jethro
    Avatar
    5 Posts

    Re: Integration Google Analytics Code Link to this post

    I was looking for answer on that also. I too have mine at the last of the page.ss before the </body> tag. I viewed the page source after the page was delivered and it has the code. It really is puzzling.

  • Sam
    Avatar
    Administrator
    679 Posts

    Re: Integration Google Analytics Code Link to this post

    This sounds like it could be more of a Google Analytics issue than a SilverStripe issue, but could you post a link to your site so we can see?

  • KatB
    Avatar
    Community Member
    94 Posts

    Re: Integration Google Analytics Code Link to this post

    I am using Google Analytics and have no trouble. It takes a while for Google Analytics to get going though. I *think* (meaning I could be horribly wrong) that Google Analytics waits until what it decides is a day is ended, to start counting from the beginning of a full day, and won't show you data until the first full day is ended. If that makes *any* sense at all.

  • jensmoewes
    Avatar
    Community Member
    7 Posts

    Re: Integration Google Analytics Code Link to this post

    I receive the data now - silverstripe needs longer to digest this data than drupal does [or at least i appears later in my analytics account]. I put the code in the particular theme directory I use htdocs/themes/paddygreen/templates and then into page.ss . . now it works. Its not the standard theme so I put the code simply in the wrong page.ss

    3918 Views
Page: 1
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.