Jump to:

17452 Posts in 4473 Topics by 1971 members

Archive

SilverStripe Forums » Archive » Image upload only works in IE

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Page: 1 2
Go to End
Author Topic: 138226 Views
  • manafta
    Avatar
    Community Member
    7 Posts

    Image upload only works in IE Link to this post

    The image upload only seems to work with Internet Explorer (I am using IE7).

    In other browsers I get the message "Files ready to upload" with a list of images. But nothing happens when I click on "Upload files listed below".

    If I am using TinyMCE, I only get the message "Uploading ... 1/1".

    Tested it with:
    - Firefox 2.0.15 (Windows/Linux)
    - Opera 9.27 (Windows/Linux)
    - Safari 3.1 (Windows)

    Using Flash version 9.0 and Silverstripe 2.2.1 and 2.2.2 rc3.

  • chiefie
    Avatar
    Community Member
    22 Posts

    Re: Image upload only works in IE Link to this post

    I'm using the Daily build 2008-05-14 since the stable version doesn't install properly on Web Drive. Anyhow, I have file upload problem too, as it seems like nothing is being uploaded. Creating folder is fine.

  • Berteh
    Avatar
    Community Member
    11 Posts

    Re: Image upload only works in IE Link to this post

    I could upload images on my localhost (running XAMPP 1.6.4, e.g. php 5.2.4, on ubuntu) with firefox, while I could not upload anything on my public host (runnning php 5.2.6)... folder creation worked in the 2 cases.

    The file & folder permission seems right on both configurations, both running Apache2.

    Hope this helps fixing this problem :/

  • manafta
    Avatar
    Community Member
    7 Posts

    Re: Image upload only works in IE Link to this post

    The problem is flash player 9.0.124. Downgraded to 9.0.48 and now it works.

  • chiefie
    Avatar
    Community Member
    22 Posts

    Re: Image upload only works in IE Link to this post

    Is SWFUpload the only the solution to use for uploading?

    It is one thing to downgrade to older version of Flash will help (haven't tested myself), but you surely cannot expect all my authors to downgrade their Flash to older version, or even the other site users to downgrade to older version of Flash when using public accessible uploading function?

    Anyone know what is changed between the 9.0.124 and 9.0.48?

  • Tim
    Avatar
    Core Development Team
    201 Posts

    Re: Image upload only works in IE Link to this post

    There seem to be a number of problems with the SWFUploader, so we've decided to remove it from the core for the final release of 2.2 which is arriving very shortly...

    Hopefully these issues with the SWFUploader will be resolved in a few months so we can included it again for the next release of SilverStripe.

  • chiefie
    Avatar
    Community Member
    22 Posts

    Re: Image upload only works in IE Link to this post

    So... what will be replacing SWFUpload (don't suggest FTP)

  • chiefie
    Avatar
    Community Member
    22 Posts

    Re: Image upload only works in IE Link to this post

    Ok... I've installed the 2.2.2 version (22 May 08) and the upload works! YAY!

    138226 Views
Page: 1 2
Go to Top

Want to know more about the company that brought you SilverStripe? Then check out SilverStripe.com

Comments on this website? Please give feedback.